Bug 2013762 - python-asyncpg: FTBFS in Fedora Rawhide
Summary: python-asyncpg: FTBFS in Fedora Rawhide
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-asyncpg
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ben Beasley
QA Contact:
URL: https://koschei.fedoraproject.org/pac...
Whiteboard:
Depends On: 1981662
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-10-13 16:44 UTC by Ben Beasley
Modified: 2021-10-13 17:16 UTC (History)
1 user (show)

Fixed In Version: python-asyncpg-0.24.0-8.fc36
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-10-13 17:16:55 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Ben Beasley 2021-10-13 16:44:32 UTC
Description of problem:
Package python-asyncpg fails to build from source in Fedora Rawhide.

Version-Release number of selected component (if applicable):
0.24.0-7.fc36

Steps to Reproduce:
koji build --scratch f36 python-asyncpg-0.24.0-7.fc36.src.rpm

Additional info:
This package is tracked by Koschei. See:
https://koschei.fedoraproject.org/package/python-asyncpg

Comment 1 Ben Beasley 2021-10-13 16:45:46 UTC
I am already skipping flake8 tests since they are “flaky” (ha!)—they can introduce spurious failures as flake8 is updated. I will work around this by patching setup.py so that linter dependencies are not generated at all.

Comment 2 Fedora Update System 2021-10-13 17:14:21 UTC
FEDORA-2021-9f79d81073 has been submitted as an update to Fedora 36. https://bodhi.fedoraproject.org/updates/FEDORA-2021-9f79d81073

Comment 3 Fedora Update System 2021-10-13 17:16:55 UTC
FEDORA-2021-9f79d81073 has been pushed to the Fedora 36 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.