Bug 201400 - HAL update hal-0.5.7.1-2.fc5 kills CD/DVD automount on Latitude X1 external drive.
HAL update hal-0.5.7.1-2.fc5 kills CD/DVD automount on Latitude X1 external d...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
5
i386 Linux
medium Severity high
: ---
: ---
Assigned To: David Zeuthen
http://folk.ntnu.no/gronslet/blog/200...
bzcl34nup
:
: 204962 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-04 16:27 EDT by Austin Jackson
Modified: 2013-03-05 22:46 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-06 12:11:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Austin Jackson 2006-08-04 16:27:29 EDT
Description of problem:
I have a Dell Latitude X1.  The computer ships with an external CDR/DVD drive
that connects through a USB port.  As of HAL update hal-0.5.7.1-2.fc5, CD's and
DVD's no longer automount.  USB sticks, SD cards, and CF cards still automount
as before.  This behavior occurs under KDE and GNOME.  Manually mounting the
media works, however.

Version-Release number of selected component (if applicable):
hal-0.5.7.1-2.fc5

How reproducible:
Always

Steps to Reproduce:
1. install hal-0.5.7.1-2.fc5
2. insert CD or DVD and wait for it to mount
3.
  
Actual results:
Nothing happens, but manually mounting the media works.

Expected results:
Media is automounted and icon appears on desktop.

Additional info:
This appears to be happening with other owners as reported in the last several
comments at the URL referenced above.
Comment 1 MartinG 2006-08-05 07:58:07 EDT
I can confirm this, same version of hal. It was working in an earlier release. 
See also http://bugs.kde.org/show_bug.cgi?id=131734

(I too have a Dell Latitude X1 with an external dvd drive, but I don't think it 
is specific to this setup)
Comment 2 Brian Millett 2006-08-05 09:34:32 EDT
I have a dell d820.  Before the hal upgrade, the cd/dvd would mount just fine. 
Due to performance issues playing dvds, I had to have hdc=noprobe as a boot
parameter.  After the upgrade, cd/dvds to not automount.

If I take out the hdc=noprobe, then cd/dvds will automount, however, dvd
playback is very eratic & slow.  To have good cd/dvd performance, I still need
the hdc=noprobe , but have no automount.
Comment 3 John Cox 2006-08-05 13:53:42 EDT
I'm having this problem with a Compaq Pressario 2102us. At this point I haven't 
been able to manually mount it either.
Comment 4 Austin Jackson 2006-08-06 09:11:01 EDT
I am not using the hdc=noprobe option, so that may be a different issue. 
Provided this is occuring on several different models, we may want to change the
title to "HAL update hal-0.5.7.1-2.fc5 kills CD/DVD automount on external USB
drive".
Comment 5 Brian Millett 2006-08-06 09:16:36 EDT
Ok, good point.
if you do a lshal, does it show the device?  Like this:

udi = '/org/freedesktop/Hal/devices/pci_8086_27c4_scsi_host_scsi_device_lun0'
  info.udi =
'/org/freedesktop/Hal/devices/pci_8086_27c4_scsi_host_scsi_device_lun0'  (string)
  linux.subsystem = 'scsi'  (string)
  linux.hotplug_type = 1  (0x1)  (int)
  scsi.type = 'cdrom'  (string)
  scsi.vendor = 'SONY'  (string)
  scsi.model = 'DVD+-RW DW-Q58A'  (string)
  info.product = 'SCSI Device'  (string)
  info.linux.driver = 'sr'  (string)
  scsi.lun = 0  (0x0)  (int)
  scsi.target = 0  (0x0)  (int)
  scsi.bus = 0  (0x0)  (int)
  scsi.host = 1  (0x1)  (int)
  info.parent = '/org/freedesktop/Hal/devices/pci_8086_27c4_scsi_host'  (string)
  info.bus = 'scsi'  (string)
  linux.sysfs_path_device =
'/sys/devices/pci0000:00/0000:00:1f.2/host1/target1:0:0/1:0:0:0'  (string)
  linux.sysfs_path =
'/sys/devices/pci0000:00/0000:00:1f.2/host1/target1:0:0/1:0:0:0'  (string)


Comment 6 Austin Jackson 2006-08-06 19:02:07 EDT
It does show up.

Here is my lshal output for the device:

<code>
udi =
'/org/freedesktop/Hal/devices/usb_device_413c_9001_noserial_if0_scsi_host_scsi_device_lun0'
  info.udi =
'/org/freedesktop/Hal/devices/usb_device_413c_9001_noserial_if0_scsi_host_scsi_device_lun0'
 (string)
  linux.subsystem = 'scsi'  (string)
  linux.hotplug_type = 1  (0x1)  (int)
  scsi.type = 'cdrom'  (string)
  scsi.vendor = 'PHILIPS'  (string)
  scsi.model = 'CDRW/DVD SCB5265'  (string)
  info.product = 'SCSI Device'  (string)
  info.linux.driver = 'sr'  (string)
  scsi.lun = 0  (0x0)  (int)
  scsi.target = 0  (0x0)  (int)
  scsi.bus = 0  (0x0)  (int)
  scsi.host = 1  (0x1)  (int)
  info.parent =
'/org/freedesktop/Hal/devices/usb_device_413c_9001_noserial_if0_scsi_host'  (string)
  info.bus = 'scsi'  (string)
  linux.sysfs_path_device =
'/sys/devices/pci0000:00/0000:00:1d.7/usb1/1-1/1-1:1.0/host1/target1:0:0/1:0:0:0'
 (string)
  linux.sysfs_path =
'/sys/devices/pci0000:00/0000:00:1d.7/usb1/1-1/1-1:1.0/host1/target1:0:0/1:0:0:0'
 (string)
</code>
Comment 7 Austin Jackson 2006-08-07 16:43:13 EDT
Workaround:

su -
wget
http://mirror.linux.duke.edu/pub/fedora/linux/core/updates/5/i386/hal-0.5.7-3.fc5.2.i386.rpm
wget
http://mirror.linux.duke.edu/pub/fedora/linux/core/updates/5/i386/hal-gnome-0.5.7-3.fc5.2.i386.rpm
rpm -Uvh --oldpackage hal-0.5.7-3.fc5.2.i386.rpm hal-gnome-0.5.7-3.fc5.2.i386.rpm
Comment 8 MartinG 2006-08-07 17:26:39 EDT
Thanks Austin, that worked for me too (I also had the devel package):
  # su -
  # wget http://mirror.linux.duke.edu/pub/fedora/linux/core/updates/5/i386/hal-
0.5.7-3.fc5.2.i386.rpm
  # wget http://mirror.linux.duke.edu/pub/fedora/linux/core/updates/5/i386/hal-
gnome-0.5.7-3.fc5.2.i386.rpm
  # wget http://mirror.linux.duke.edu/pub/fedora/linux/core/updates/5/i386/hal-
devel-0.5.7-3.fc5.2.i386.rpm
  # rpm -Uvh --oldpackage hal-0.5.7-3.fc5.2.i386.rpm hal-gnome-0.5.7-
3.fc5.2.i386.rpm hal-devel-0.5.7-3.fc5.2.i386.rpm
  # service haldaemon restart
(I also stopped and started kcontrol/KDE Components/Service Manager: KDED Media 
Manager and Media Notifier)

Now, when I insert a CDROM two Konqueror windows open showing the cd contents...
(Compact Flash and Secure Digital cards work as before)

So this pretty much confirmes this problem in hal. Any devs out there have a 
clue?

By the way, maybe somone can confirm this related kde bug: http://bugs.kde.org/
show_bug.cgi?id=131734
Comment 9 John (J5) Palmieri 2006-08-07 17:32:19 EDT
Are you using the latest kernel?  hal-0.5.7-3.fc5.2 should be broken with the
latest kernel.
Comment 10 MartinG 2006-08-07 18:59:07 EDT
# uname -r
2.6.17-1.2157_FC5
Comment 11 Austin Jackson 2006-08-07 19:04:03 EDT
I have the same kernel as Martin's.  I am not experiencing any trouble with the
old HAL.
Comment 12 Ilya Ryabinkin 2006-08-16 01:58:54 EDT
Confirm this bug on Dell Latitude D610 with NEC DVD+/-RW drive. Using it as
ordinary IDE drive (hdc) may solve the problem albeit you cannot turn on DMN
Comment 13 cornel panceac 2006-08-19 15:14:12 EDT
same thing happened to my computer, homemade, ecs mobo.
after downgrading hal as suggested above, everything worked again as it's
supposed to.
kernel 2.6.17-1.2174_FC5
Comment 14 Kevin R. Page 2006-08-22 09:30:59 EDT
Me Too: USB DVD-RW; two different FC5 machines (one laptop, one desktop);
downgrading to hal-0.5.7-3.fc5.2.i386.rpm fixes the issue.
Comment 15 Brian Millett 2006-08-22 11:10:11 EDT
Well, I'm an ALMOST me too.  I have to use the following 
http://people.freedesktop.org/~david/rh185557/hal-0.5.7-3davidz1.src.rpm and
recompile it.  I need the patch that will recognize pcmcia compact flash cards
as disks.  The hal-0.5.7-3.fc5.2.i386.rpm does not recognize pcmcia compact
flash drives.  The hal-0.5.7.1-2.fc5 does recognize the pcmcia compact flash
drives, but alas not the CD/DVD in scsi mode.
Comment 16 Jon 2006-09-01 17:42:50 EDT
*** Bug 204962 has been marked as a duplicate of this bug. ***
Comment 17 Seth Vidal 2006-10-15 23:23:24 EDT
me too. This completely fixed the problem for me on a dell d420.

this should maybe get escalated a bit since it will break a lot of people's systems.

bumping to a 'high' severity.
Comment 18 MartinG 2006-10-16 03:17:45 EDT
This seems to be fixed in hal-0.5.8.1-4.fc6 (Dell Latitude X1 with external dvd 
writer)
Comment 19 Brian Millett 2006-10-16 16:22:04 EDT
If so, that would be nice to be rolled back into fc5.  The src rpm has too many
dependencies:

error: Failed build dependencies:
        dbus-devel >= 0.90 is needed by hal-0.5.8.1-4.i386
        dbus-glib-devel >= 0.70 is needed by hal-0.5.8.1-4.i386
        dbus-glib >= 0.70 is needed by hal-0.5.8.1-4.i386
        libvolume_id-devel >= 089-1 is needed by hal-0.5.8.1-4.i386
Comment 20 Jon 2006-10-29 17:39:59 EST
Bug is now fixed in Fedora Core 6.
Works for me. 
Comment 21 Brian Millett 2006-10-29 22:41:45 EST
I wish.  Still the same with fc6 and a dell d820.
Comment 22 Brian Millett 2006-10-30 09:20:19 EST
I guess I was on a Cards World Series hangover.
It works on my dell now.  Sorry.
Comment 23 peter young 2006-10-31 10:47:45 EST
I have HP nx6125 with internal DVD writer.
This used to automount but sometime in the last few month it nolonger works.
I am on the latest FC5 updates, but have not tried FC6 yet.

Going back to hal 5.7-3 does not fix it.
Root can mount manually - other users cannot.

I have modified the /etc/dbus-1/system.d/hal.conf file to allow write access 
be default to to Hal.Device.Volume

gnome-volume-manager --smdisable is in the staryup seesions, but doesn;t 
appera to be running.

Is there a way to fix this, and does it need a separate case ?

Comment 24 MartinG 2007-01-09 14:13:43 EST
Hm, this bug seems to be back in FC6 using hal-0.5.8.1-6.fc6 on my Dell 
Latitude X1 using kernel 2.6.18-1.2869.fc6 with selinux=0 boot parameter. 

Workaround:
# chmod a+rwx /dev/sg*
# chmod a+rwx /dev/scd*
# chmod a+rwx /dev/usbdev*

(In /dev I have: usbdev1.1_ep00  usbdev2.3_ep00  usbdev2.3_ep82  
usbdev4.1_ep00  usbdev5.3_ep00 usbdev1.1_ep81  usbdev2.3_ep02  usbdev2.3_ep83 
usbdev4.1_ep81  usbdev5.3_ep02 usbdev2.1_ep00  usbdev2.3_ep03  usbdev3.1_ep00 
usbdev5.1_ep00  usbdev5.3_ep88 usbdev2.1_ep81  usbdev2.3_ep81  usbdev3.1_ep81  
usbdev5.1_ep81)

Then I re-insert the Audio CD, and the KDE pop-up appears and I can rip it with 
kaudiocreator.
Comment 25 Bug Zapper 2008-04-03 23:26:36 EDT
Fedora apologizes that these issues have not been resolved yet. We're
sorry it's taken so long for your bug to be properly triaged and acted
on. We appreciate the time you took to report this issue and want to
make sure no important bugs slip through the cracks.

If you're currently running a version of Fedora Core between 1 and 6,
please note that Fedora no longer maintains these releases. We strongly
encourage you to upgrade to a current Fedora release. In order to
refocus our efforts as a project we are flagging all of the open bugs
for releases which are no longer maintained and closing them.
http://fedoraproject.org/wiki/LifeCycle/EOL

If this bug is still open against Fedora Core 1 through 6, thirty days
from now, it will be closed 'WONTFIX'. If you can reporduce this bug in
the latest Fedora version, please change to the respective version. If
you are unable to do this, please add a comment to this bug requesting
the change.

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we are following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

And if you'd like to join the bug triage team to help make things
better, check out http://fedoraproject.org/wiki/BugZappers
Comment 26 Bug Zapper 2008-05-06 12:11:44 EDT
This bug is open for a Fedora version that is no longer maintained and
will not be fixed by Fedora. Therefore we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen thus bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.