Bug 20149 - Upgrade from 6.2 to 7.0 cannot continue
Upgrade from 6.2 to 7.0 cannot continue
Status: CLOSED DUPLICATE of bug 18019
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-01 11:36 EST by Need Real Name
Modified: 2005-10-31 17:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-03 15:12:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-11-01 11:36:13 EST
When upgrade from Redhat 6.2 to 7.0, the process always abort while checking
installed packages. Cannot continue with the upgrade. Below is the traceback.

Traceback (innermost last):
  File "/usr/bin/anaconda.real", line 438, in ?
    intf.run(todo, test = test)
  File 
"/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1028, in run
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 279, in 
__call__
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 941, in upgradeFindPackages
  File 
"/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 539, in getCompsList
  File 
"/var/tmp/anaconda-7.0.1//usr/lib/anaconda/harddrive.py", 
line 43, in readComps
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 459, in __init__
  File 
"/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 428, in readCompsFile
  File 
"/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 101, in __getitem__
KeyError: usermode

Local variables in innermost 
frame:
self: <comps.HeaderList instance at 821b7a0>
item: usermode

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iharddrive
HardDriveInstallMethod
p4
(dp5
S'fstype'
p6
S'ext2'
p7
sS'isMounted'
p8
I0
sS'fnames'
p9
(dp10

<failed>
Comment 1 Need Real Name 2000-11-01 13:33:17 EST
I ftped Redhat 7.0 RPMS and base in
/usr/src/redhat-7.0/RedHat
I am currently runing 6.2, trying to upgrades to 7.0
Applied the Anaconda updates, update-disk-20001009.img,
the same problem still exists.
Comment 2 Michael Fulbright 2000-11-03 15:12:35 EST
It appears either some packages are missing or corrupt.

When you download make sure you use the binary ftp option.

*** This bug has been marked as a duplicate of 18019 ***

Note You need to log in before you can comment on or make changes to this bug.