Bug 2015025 - Payload imagestream new tags not properly updated during cluster upgrade
Summary: Payload imagestream new tags not properly updated during cluster upgrade
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Cluster Version Operator
Version: 4.9
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.8.z
Assignee: Jack Ottofaro
QA Contact: XiuJuan Wang
URL:
Whiteboard:
Depends On: 2015024
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-10-18 09:13 UTC by OpenShift BugZilla Robot
Modified: 2021-11-23 11:33 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-11-23 11:33:27 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-version-operator pull 679 0 None open [release-4.8] Bug 2015025: lib/resourcemerge/imagestream.go: Copy all data for new tag reference 2021-10-26 13:44:04 UTC
Red Hat Product Errata RHBA-2021:4716 0 None None None 2021-11-23 11:33:50 UTC

Description OpenShift BugZilla Robot 2021-10-18 09:13:32 UTC
+++ This bug was initially created as a clone of Bug #2014071 +++

Created attachment 1832928 [details]
driver-toolkit tag broken after cluster upgrade

Description of problem:

When the CVO updates an imagestream which contains *new* tags, the new tags are created without a name.


How reproducible: 100%


Steps to Reproduce:

look at the tags of the driver-toolkit imagestream after a cluster upgrade (upgrade must include an update of RHCOS version):

> oc get is/driver-toolkit -n openshift  -oyaml


Actual results:

the imagesteam tag is populated with the right `from` image, but the `name` field is empty


Expected results:

the imagestream tag must be populated with their name, according to the specification of the new imagestream


Additional info:

in this block: https://github.com/openshift/cluster-version-operator/blob/14d93a158e163f06c2ee936ee29c9c94da7f35fe/lib/resourcemerge/imagestream.go#L22-L27

the value of `required.Name` is lost and not set in `existing.Name`

Comment 4 XiuJuan Wang 2021-11-16 03:15:29 UTC
Verified when upgrade 4.7.0-0.nightly-2021-11-15-192525 to 4.8.0-0.nightly-2021-11-15-191743

Comment 7 errata-xmlrpc 2021-11-23 11:33:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.8.21 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:4716


Note You need to log in before you can comment on or make changes to this bug.