Bug 201529 - kernel 2.6.17 won't boot on AMD Athlon X2 - Asus M2NPV-VM
kernel 2.6.17 won't boot on AMD Athlon X2 - Asus M2NPV-VM
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
MassClosed
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-07 02:44 EDT by Richi Plana
Modified: 2008-01-19 23:41 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-19 23:41:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richi Plana 2006-08-07 02:44:43 EDT
Description of problem:
The kernel (kernel-2.6.17-1.2157_FC5) boot process hangs on an AMD Athlon 64 X2
3800+ (socket AM2) - Asus M2NPV-VM system.

There was a discussion on the kernel mailing list about the problem here:
http://www.uwsg.iu.edu/hypermail/linux/kernel/0607.1/1649.html ... At first, the
kernel init hangs after the line:

io scheduler cfq registered

After I remove the USB Legacy Support in the BIOS, the kernel goes past that
line in the init process and hangs in the serial comms init. So I disabled the
serial ports in the BIOS and then the kernel hangs on Probing of ide interfaces.
Which made me think it's probably not the USB subsystem after all.

One thing that's noteworthy is that even with 2.6.15 kernels (which do finish
booting), the message:

..MP-BIOS bug: 8254 timer not connected to IO-APIC
 failed.
Using local APIC timer interrupts.

appears in the kernel message outputs which may or may not be related (APIC).

Version-Release number of selected component (if applicable):
kernel-2.6.17-1.2157_FC5

How reproducible:
Always

Steps to Reproduce:
1. Boot up a 2.6.17 kernel on an AMD Athlon X2 - Asus M2NPV-VM system
2.
3.
  
Actual results:
System hangs

Expected results:
System doesn't hang :)

Additional info:
Comment 1 Dave Jones 2006-10-16 15:38:40 EDT
A new kernel update has been released (Version: 2.6.18-1.2200.fc5)
based upon a new upstream kernel release.

Please retest against this new kernel, as a large number of patches
go into each upstream release, possibly including changes that
may address this problem.

This bug has been placed in NEEDINFO state.
Due to the large volume of inactive bugs in bugzilla, if this bug is
still in this state in two weeks time, it will be closed.

Should this bug still be relevant after this period, the reporter
can reopen the bug at any time. Any other users on the Cc: list
of this bug can request that the bug be reopened by adding a
comment to the bug.

In the last few updates, some users upgrading from FC4->FC5
have reported that installing a kernel update has left their
systems unbootable. If you have been affected by this problem
please check you only have one version of device-mapper & lvm2
installed.  See bug 207474 for further details.

If this bug is a problem preventing you from installing the
release this version is filed against, please see bug 169613.

If this bug has been fixed, but you are now experiencing a different
problem, please file a separate bug for the new problem.

Thank you.
Comment 2 Richi Plana 2006-10-30 11:12:07 EST
Unfortunately, I've returned the ASUS mobo and gone back to Gigabyte (which has
been a 6 for 6 for me in the last 4 years). I do hope someone picks up from here
to test, though.
Comment 3 oliver 2006-12-15 17:18:42 EST
I tried to install FC6, which has a 2.6.18 kernel.  The installation disk
kernel won't even boot.  Don't know how to get any x86_64 onto this machine at
all, only appears usable in 32bit.
Comment 4 Trond Danielsen 2007-02-19 17:05:34 EST
I have a computer with the same motherboard, and the problem has been solved in
the latest kernel (kernel-2.6.19-1.2911). It is possible to install FC6 on
computers with this motherboard by booting the noapic boot parameter.
Comment 5 Jon Stanley 2008-01-19 23:41:37 EST
(this is a mass-close to kernel bugs in NEEDINFO state)

As indicated previously there has been no update on the progress of this bug
therefore I am closing it as INSUFFICIENT_DATA. Please re-open if the issue
still occurs for you and I will try to assist in its resolution. Thank you for
taking the time to report the initial bug.

If you believe that this bug was closed in error, please feel free to reopen
this bug.

Note You need to log in before you can comment on or make changes to this bug.