This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 201535 - Opal gets build with wrong dependencies
Opal gets build with wrong dependencies
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: opal (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Veillard
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-07 04:03 EDT by Jan "Yenya" Kasprzak
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 2.2.3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-07 12:13:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jan "Yenya" Kasprzak 2006-08-07 04:03:28 EDT
Description of problem:
When rebuilding the opal library, it gets build with ELF dependency on
libpt.so.1.11.0, while the actual pwlib library on this system was 1.10.

Version-Release number of selected component (if applicable):
opal-2.2.2-1.1
pwlib-1.10.1-5
pwlib-devel-1.10.1-5

How reproducible:
100%

Steps to Reproduce:
1. rpmbuild --rebuild pwlib-1.10.1-5.src.rpm (with a fix from bug #201532)
2. rpm -Uvh pwlib-1.10.1-5.x86_64.rpm pwlib-devel-1.10.1-5.x86_64.rpm
3. rpmbuild --rebuild opal-2.2.2-1.1.src.rpm
4. rpm -Uvh opal-2.2.2-1.1.x86_64.rpm
  
Actual results:
error: Failed dependencies:
        libpt.so.1.11.0()(64bit) is needed by opal-2.2.2-1.1.x86_64


Expected results:
opal should be installed, because it is compiled against pwlib-1.10.

Additional info:
even after rpm -bp opal.spec; cd ../BUILD/opal/*; ./configure; make
the shared library is built with incorrect dependency on pwlib, according to
ldd lib/libopal_linux_x86_64_r.so.2.2.2

This is FC5/x86_64 system, I am trying to recompile pwlib, opal and ekiga from
rawhide/FC6t1.
Comment 1 Daniel Veillard 2006-11-07 12:13:15 EST
I think this problem was fixed, I rechecked all version numbers in the spec file
when pushing a new version of opal yesterday.

Daniel

Note You need to log in before you can comment on or make changes to this bug.