Bug 201634 - No support for multi-row workspace layouts
No support for multi-row workspace layouts
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: compiz (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
:
: 206982 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-07 16:59 EDT by Søren Sandmann Pedersen
Modified: 2014-06-18 05:08 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-19 13:42:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
No vertical bars in workspace switcher (10.12 KB, image/png)
2006-08-23 16:12 EDT, Bojan Smojver
no flags Details
Workspace switcher applet (4.24 KB, image/png)
2006-09-04 06:52 EDT, Matthias Saou
no flags Details

  None (edit)
Description Søren Sandmann Pedersen 2006-08-07 16:59:36 EDT
Problem:

compiz does not support workspaces layed out in multiple rows.
Comment 1 Bojan Smojver 2006-08-23 16:08:44 EDT
It would also seem that workspaces in workspace switcher are not separated by
vertical bars, which makes you kind of "guess" where the workspace is supposed
to be. I'll attach a screen dump.
Comment 2 Bojan Smojver 2006-08-23 16:12:20 EDT
Created attachment 134749 [details]
No vertical bars in workspace switcher
Comment 3 Bojan Smojver 2006-09-03 23:25:04 EDT
The most recent compiz and workspace switcher combo (as of Sep 4 2006) creates
some weird effects on the workspace switcher display. No widows are shown in the
switcher at all...
Comment 4 Matthias Saou 2006-09-04 06:52:26 EDT
Created attachment 135488 [details]
Workspace switcher applet

With today's Rawhide (Sep. 4), I am not seeing weird effects in the workspace
switcher, but I am unable to have it display on a single line like before. I
have 8 "horizontal" workspaces, and they all appear tiny at the very top of the
applet. Note that clicking below one of the workspaces in the applet also takes
me to that workspace.

Ideally, changing the number of workspaces from within the applet's preferences
should work (it currently doesn't, one must edit the gconf entry), and if there
is no way to have multiple rows, maybe greying out the option and having it set
to "1" when running compiz would be best (at least for now).
Comment 5 Thorsten Leemhuis 2006-09-11 03:00:34 EDT
(In reply to comment #4)
> [...]
> I have 8 "horizontal" workspaces, and they all appear tiny at the very top of
> the applet. Note that clicking below one of the workspaces in the applet also 
> takes me to that workspace.

I can confirm that with latest rawhide here on x86_64.
Comment 6 Thorsten Leemhuis 2006-09-17 03:59:42 EDT
(In reply to comment #5)
> (In reply to comment #4)
> > [...]
> > I have 8 "horizontal" workspaces, and they all appear tiny at the very top of
> > the applet. Note that clicking below one of the workspaces in the applet also 
> > takes me to that workspace.
> I can confirm that with latest rawhide here on x86_64.

Saw it on i386 too, but was fixed with the first rawhide update after test3. But
the vertical bars are still missing

Comment 7 Kevin DeKorte 2006-09-17 08:46:10 EDT
This problem is NOT fixed for me on rawhide/i386. I still have the tiny desktops
in the space of one icon. I am currently upto date.
Comment 8 Thorsten Leemhuis 2006-09-18 01:24:25 EDT
(In reply to comment #7)
> This problem is NOT fixed for me on rawhide/i386.

Well, I'm at my second rawhide machine now (it's the x86_64 one). It's fixed
there for me, too. But the vertical bars are still missing

Comment 9 Bojan Smojver 2006-09-18 02:02:05 EDT
Regarding comments #6, #7 and #8, I still see the problem on i386. Weird. Maybe
some configuration setting needs to be flushed?
Comment 10 Matthias Saou 2006-09-18 05:21:19 EDT
In my case, a few things :
- The size of the workspaces on the workspace switcher has been fixed. They're
full height, and when I choose more than one row in the preferences, they change
size (although there are no actual workspaces below, it seems)
- The vertical bars to separate the worskaces are missing indeed. This makes it
hard to know how many workspaces there are when they're still empty.
- When enabling desktop effects, I have applications on many workspaces...
compiz took quite some time to get run it seems, and all open windows ended on
the first workspaces, except a few which were nowhere to be found... I had to
disable desktop effects to find them again (all on my first metacity worskpace...).
- Choosing a number of workspaces in the preferences of the workspace switcher
has no effect on compiz it seems. I have 6 configured (using GConf), and can't
add or remove any from there.
Comment 11 Kevin DeKorte 2006-09-18 08:39:55 EDT
(In reply to comment #8)
> (In reply to comment #7)
> > This problem is NOT fixed for me on rawhide/i386.
> 
> Well, I'm at my second rawhide machine now (it's the x86_64 one). It's fixed
> there for me, too. But the vertical bars are still missing

Just to be clear, when using compiz (Desktop Effects Enabled) the workspace
switcher is very narrow and windows in the switcher are tiny. I'm seeing the
same thing as the attachment 'Workspace switcher applet'. When I use metacity
the workspace switcher appears fine. I believe the separator lines are 
controlled by the theme.

Also, I believe when switching from metacity to compiz you will always lose the
placement of your windows.
Comment 12 Thorsten Leemhuis 2006-09-18 08:59:56 EDT
(In reply to comment #11)
> > Well, I'm at my second rawhide machine now (it's the x86_64 one). It's fixed
> > there for me, too. But the vertical bars are still missing
> Just to be clear, when using compiz (Desktop Effects Enabled) the workspace
> switcher is very narrow and windows in the switcher are tiny. I'm seeing the
> same thing as the attachment 'Workspace switcher applet'. [...]

Just to be clear, that was exactly what I saw when I was on the rawhide state
around test3. Now (e.g. after test3) it's better *for me* on my two machines. 

> Also, I believe when switching from metacity to compiz you will always lose the
> placement of your windows.

Yeah, happend here, too.
Comment 13 Anton Keks 2006-09-19 12:07:20 EDT
*** Bug 206982 has been marked as a duplicate of this bug. ***
Comment 14 Søren Sandmann Pedersen 2006-09-19 13:42:43 EDT
This bug should be fixed, when releng moves the new build over.

Note that you will also need a new gnome-panel to try it out.

The missing vertical bars have nothing to do with this bug. If you think that
should be changed, file a different bug against gnome-panel.
Comment 15 Kevin DeKorte 2006-09-20 15:38:53 EDT
The workspace switcher now looks correct with compiz when
gnome-panel-2.16.0-3.fc6 is installed on my machine. No more tiny icons.
Comment 16 Bojan Smojver 2006-09-20 16:29:59 EDT
Yep, I concur with comment #15. And I really like the fact that finally more
than 4 viewports (hopefully, soon to be workspaces :-) are now possible.

I did have to edit the configuration directly to remove the workspace name
though, because it's not a Preferences option. I'm guessing that will also get
fixed when viewports become workspaces.
Comment 17 rob 2006-10-26 07:45:26 EDT
I am using FC6 i386 (zod) with compiz (desktop effects enabled) and
gnome-panel-2.16.0-4.fc6 installed and I have the tiny icons!!

Note You need to log in before you can comment on or make changes to this bug.