Bug 201706 - Crashes on document load
Crashes on document load
Status: CLOSED DUPLICATE of bug 201546
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-08 09:40 EDT by Bill Nottingham
Modified: 2014-03-16 23:01 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-08 09:44:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2006-08-08 09:40:01 EDT
When I load the attached PDF, I get:

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1208247792 (LWP 3631)]
0x016810fc in com::sun::star::i18n::BreakIterator_Unicode::getLineBreak
(this=0xb20b817c, 
    Text=@0xbff54a24, nStartPos=-1074444164, rLocale=@0xbff549d0, nMinBreakPos=0, 
    hOptions=@0xbff549c4, bOptions=@0xbff549b8)
    at
/usr/src/debug/OOC680_m7/i18npool/source/breakiterator/breakiterator_unicode.cxx:361
361                     if (Text[nStartPos--] == WJ)
Current language:  auto; currently c++
(gdb) print nStartPos
$1 = -1074444164
(gdb) print Text
$2 = (const rtl::OUString &) @0xbff54a24: {pData = 0xb1d3a658}
#0  0x016810fc in com::sun::star::i18n::BreakIterator_Unicode::getLineBreak
(this=0xb20b817c, 
    Text=@0xbff54a24, nStartPos=-1074444164, rLocale=@0xbff549d0, nMinBreakPos=0, 
    hOptions=@0xbff549c4, bOptions=@0xbff549b8)
    at
/usr/src/debug/OOC680_m7/i18npool/source/breakiterator/breakiterator_unicode.cxx:361
#1  0x0167d57d in com::sun::star::i18n::BreakIteratorImpl::getLineBreak
(this=0xb2ce21e0, 
    Text=@0xbff54a24, nStartPos=36, rLocale=@0xbff549d0, nMinBreakPos=0,
hOptions=@0xbff549c4, 
    bOptions=@0xbff549b8)
    at
/usr/src/debug/OOC680_m7/i18npool/source/breakiterator/breakiteratorImpl.cxx:249
#2  0x033ac786 in ImpEditEngine::ImpBreakLine (this=0xb2d8d334,
pParaPortion=0xb1f06a4c, 
    pLine=0xb1dd8588, pPortion=0xb1de5650, nPortionStart=0, nRemainingWidth=18243, 
    bCanHyphenate=0 '\0') at
/usr/src/debug/OOC680_m7/svx/source/editeng/impedit3.cxx:1769
#3  0x033af3f1 in ImpEditEngine::CreateLines (this=0xb2d8d334, nPara=0,
nStartPosY=0)
    at /usr/src/debug/OOC680_m7/svx/source/editeng/impedit3.cxx:1242
#4  0x033b0162 in ImpEditEngine::FormatDoc (this=0xb2d8d334)
    at /usr/src/debug/OOC680_m7/svx/source/editeng/impedit3.cxx:409
#5  0x033b29bf in ImpEditEngine::FormatFullDoc (this=0xb2d8d334)
    at /usr/src/debug/OOC680_m7/svx/source/editeng/impedit3.cxx:366
#6  0x03386030 in EditEngine::SetControlWord (this=0xb2d6628c, nWord=17206361)
    at /usr/src/debug/OOC680_m7/svx/source/editeng/editeng.cxx:1703
#7  0x033cc89d in Outliner::SetControlWord (this=0xb2d7331c, nWord=17206361)
    at /usr/src/debug/OOC680_m7/svx/source/outliner/outlin2.cxx:371
#8  0x035ccf3f in SdrTextObj::TakeTextRect (this=0xb209ac50, rOutliner=@0xb2d7331c, 
    rTextRect=@0xbff55020, bNoEditText=0, pAnchorRect=0xbff55010, bLineWidth=1
'\001')
    at /usr/src/debug/OOC680_m7/svx/source/svdraw/svdotext.cxx:1018
#9  0x035cd5d6 in SdrTextObj::ImpSetupDrawOutlinerForPaint (this=0xb209ac50,
bContourFrame=0, 
    rOutliner=@0xb2d7331c, rTextRect=@0xbff55020, rAnchorRect=@0xbff55010, 
    rPaintRect=@0xbff55000, rFitXKorreg=@0xbff55040)
    at /usr/src/debug/OOC680_m7/svx/source/svdraw/svdotext.cxx:1914
#10 0x035ce3be in SdrTextObj::DoPaintObject (this=0xb209ac50, rXOut=@0xb1f38dd0, 
    rInfoRec=@0xb1b7f16c) at
/usr/src/debug/OOC680_m7/svx/source/svdraw/svdotext.cxx:1309
#11 0x035d5a42 in SdrRectObj::DoPaintObject (this=0xb209ac50, rXOut=@0xb1f38dd0, 
    rInfoRec=@0xb1b7f16c) at
/usr/src/debug/OOC680_m7/svx/source/svdraw/svdorect.cxx:443
#12 0x035b23ff in sdr::contact::ViewContactOfSdrObj::PaintObject (this=0xb20b4284, 
    rDisplayInfo=@0xbff5548c, rPaintRectangle=@0xbff550f8,
rAssociatedVOC=@0xb1b50a94)
    at /usr/src/debug/OOC680_m7/svx/source/sdr/contact/viewcontactofsdrobj.cxx:260
#13 0x035b7f29 in sdr::contact::ViewObjectContact::PaintObject (this=0xb1b50a94, 
    rDisplayInfo=@0xbff5548c)
    at /usr/src/debug/OOC680_m7/svx/source/sdr/contact/viewobjectcontact.cxx:288
#14 0x02b9e484 in sd::ViewRedirector::PaintObject (this=0xbff555cc,
rOriginal=@0xb1b50a94, 
    rDisplayInfo=@0xbff5548c) at
/usr/src/debug/OOC680_m7/sd/source/ui/view/sdview.cxx:456
#15 0x035b7c3f in sdr::contact::ViewObjectContact::PaintObjectHierarchy
(this=0xb1b50a94, 
    rDisplayInfo=@0xbff5548c)
    at /usr/src/debug/OOC680_m7/svx/source/sdr/contact/viewobjectcontact.cxx:367
#16 0x035b7cf1 in sdr::contact::ViewObjectContact::PaintDrawHierarchy
(this=0xb1b509b4, 
    rDisplayInfo=@0xbff5548c)
    at /usr/src/debug/OOC680_m7/svx/source/sdr/contact/viewobjectcontact.cxx:326
#17 0x035b7c58 in sdr::contact::ViewObjectContact::PaintObjectHierarchy
(this=0xb1b509b4, 
    rDisplayInfo=@0xbff5548c)
    at /usr/src/debug/OOC680_m7/svx/source/sdr/contact/viewobjectcontact.cxx:376
#18 0x035b6bbe in sdr::contact::ObjectContactOfPageView::DoProcessDisplay
(this=0xb51f2d3c, 
    rDisplayInfo=@0xbff5548c)
    at
/usr/src/debug/OOC680_m7/svx/source/sdr/contact/objectcontactofpageview.cxx:550
#19 0x035b7659 in sdr::contact::ObjectContactOfPageView::ProcessDisplay
(this=0xb51f2d3c, 
    rDisplayInfo=@0xbff5548c)
    at
/usr/src/debug/OOC680_m7/svx/source/sdr/contact/objectcontactofpageview.cxx:427
#20 0x036666ce in SdrPageViewWindow::Redraw (this=0xb1b53770, rReg=@0xbff5569c,
nPaintMode=0, 
    pId=0x0, pRedirector=0xbff555cc)
    at /usr/src/debug/OOC680_m7/svx/source/svdraw/svdpagv.cxx:849
#21 0x0366697b in SdrPageView::CompleteRedraw (this=0xb1eeeb84,
pGivenTarget=0xb52ff670, 
    rReg=@0xbff5569c, nPaintMode=0, pRedirector=0xbff555cc)
    at /usr/src/debug/OOC680_m7/svx/source/svdraw/svdpagv.cxx:1397
#22 0x0366bfa8 in SdrPaintView::CompleteRedraw (this=0xb683e008, pOut=0xb52ff670, 
    rReg=@0xbff5569c, nPaintMode=0, pRedirector=0xbff555cc)
    at /usr/src/debug/OOC680_m7/svx/source/svdraw/svdpntv.cxx:1126
#23 0x02b9d05c in sd::View::CompleteRedraw (this=0xb683e008, pOutDev=0xb52ff670, 
    rReg=@0xbff5569c, pRedirector=0xbff555cc)
    at /usr/src/debug/OOC680_m7/sd/source/ui/view/sdview.cxx:483
#24 0x02be0cbc in sd::DrawView::CompleteRedraw (this=0xb683e008,
pOutDev=0xb52ff670, 
    rReg=@0xbff5569c, pRedirector=0x0)
    at /usr/src/debug/OOC680_m7/sd/source/ui/view/drawview.cxx:671
#25 0x02d6b8cc in sd::PreviewRenderer::PaintPage (this=0xb1bcd37c, pPage=0xb535d618)
    at /usr/src/debug/OOC680_m7/sd/source/ui/tools/PreviewRenderer.cxx:294
#26 0x02d6bb2e in sd::PreviewRenderer::RenderPage (this=0xb1bcd37c,
pPage=0xb535d618, 
    aPixelSize={<Pair> = {nA = 212, nB = 159}, <No data fields>}, 
    rSubstitutionText=@0xbff55754)
    at /usr/src/debug/OOC680_m7/sd/source/ui/tools/PreviewRenderer.cxx:119
#27 0x02da24c7 in sd::slidesorter::cache::PreviewBitmapFactory2::CreateBitmap (
    this=0xb1bcd378, rContact=@0xb1bce044)
    at
/usr/src/debug/OOC680_m7/sd/source/ui/slidesorter/cache/SlsPreviewBitmapFactory2.hxx:79
#28 0x02da3927 in
sd::slidesorter::cache::QueueProcessor<sd::slidesorter::cache::GenericRequestQueue<sd::slidesorter::view::PageObjectViewObjectContact>,
sd::slidesorter::view::PageObjectViewObjectContact,
sd::slidesorter::cache::PreviewBitmapFactory2>::ProcessRequest (this=0xb1bcd33c)
    at
/usr/src/debug/OOC680_m7/sd/source/ui/slidesorter/cache/SlsQueueProcessor.hxx:219
#29 0x02da7033 in sd::slidesorter::cache::QueueProcessorBase::ProcessRequest
(this=0xb1bcd33c, 
    pTimer=0xb1bcd34c)
    at
/usr/src/debug/OOC680_m7/sd/source/ui/slidesorter/cache/SlsQueueProcessor.cxx:99
#30 0x02da7048 in
sd::slidesorter::cache::QueueProcessorBase::LinkStubProcessRequest (
    pThis=0xb1bcd33c, pCaller=0xb1bcd34c)
    at
/usr/src/debug/OOC680_m7/sd/source/ui/slidesorter/cache/SlsQueueProcessor.cxx:97
#31 0x06f55b5a in Link::Call (this=0xbff54a24, pCaller=0xb1bcd34c)
    at /usr/src/debug/OOC680_m7/solver/680/unxlngi6.pro/inc/tools/link.hxx:154
#32 0x06f6216a in Timer::Timeout (this=0xb1bcd34c)
    at /usr/src/debug/OOC680_m7/vcl/source/app/timer.cxx:284
#33 0x06f62308 in ImplTimerCallbackProc ()
    at /usr/src/debug/OOC680_m7/vcl/source/app/timer.cxx:172
#34 0x00e7b26f in SalTimer::CallCallback (this=0xb4797b90) at
../../../inc/saltimer.hxx:80
#35 0x00e7b0a8 in SalData::Timeout (this=0xb7579b98)
    at /usr/src/debug/OOC680_m7/vcl/unx/source/app/saltimer.cxx:66
#36 0x00e120d9 in GtkXLib::timeoutFn (data=0xb7f9e308)
    at /usr/src/debug/OOC680_m7/vcl/unx/gtk/app/gtkdata.cxx:583
#37 0x00d86916 in g_source_get_current_time () from /lib/libglib-2.0.so.0
#38 0x00d86342 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#39 0x00d8931f in g_main_context_check () from /lib/libglib-2.0.so.0
#40 0x00d89885 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#41 0x00e11033 in GtkXLib::Yield (this=0xb7f9e308, bWait=1 '\001')
    at /usr/src/debug/OOC680_m7/vcl/unx/gtk/app/gtkdata.cxx:697
#42 0x00e821f9 in X11SalInstance::Yield (this=0xb7579b48, bWait=1 '\001')
    at /usr/src/debug/OOC680_m7/vcl/unx/source/app/salinst.cxx:290
#43 0x06f5df90 in Application::Yield ()
    at /usr/src/debug/OOC680_m7/vcl/source/app/svapp.cxx:545
#44 0x06f5e014 in Application::Execute ()
    at /usr/src/debug/OOC680_m7/vcl/source/app/svapp.cxx:507
#45 0x07fc0789 in desktop::Desktop::Main (this=0xbff55c7c)
    at /usr/src/debug/OOC680_m7/desktop/source/app/app.cxx:1720
#46 0x06f61da2 in ImplSVMain () at
/usr/src/debug/OOC680_m7/vcl/source/app/svmain.cxx:242
#47 0x06f61e55 in SVMain () at
/usr/src/debug/OOC680_m7/vcl/source/app/svmain.cxx:273
#48 0x07fba4f9 in sal_main (argc=2, argv=0xbff55d74)
    at /usr/src/debug/OOC680_m7/desktop/source/app/main.cxx:77
#49 0x07fba545 in main (argc=2, argv=0xbff55d74)
    at /usr/src/debug/OOC680_m7/desktop/source/app/main.cxx:71
#50 0x00ad5214 in __libc_start_main () from /lib/libc.so.6
#51 0x08048481 in _start ()
(gdb) info threads
  7 Thread -1208382560 (LWP 3632)  0xb7fdf402 in __kernel_vsyscall ()
  6 Thread -1233425504 (LWP 3633)  0xb7fdf402 in __kernel_vsyscall ()
  5 Thread -1243980896 (LWP 3634)  0xb7fdf402 in __kernel_vsyscall ()
  4 Thread -1256502368 (LWP 3635)  0xb7fdf402 in __kernel_vsyscall ()
  3 Thread -1272407136 (LWP 3636)  0xb7fdf402 in __kernel_vsyscall ()
* 1 Thread -1208247792 (LWP 3631)  0x016810fc in
com::sun::star::i18n::BreakIterator_Unicode::getLineBreak (this=0xb20b817c,
Text=@0xbff54a24, nStartPos=-1074444164, rLocale=@0xbff549d0, 
    nMinBreakPos=0, hOptions=@0xbff549c4, bOptions=@0xbff549b8)
    at
/usr/src/debug/OOC680_m7/i18npool/source/breakiterator/breakiterator_unicode.cxx:361
Comment 1 Bill Nottingham 2006-08-08 09:40:40 EDT
OO.o info is:

(I) x.org loaded video driver of...
(II) Loading /usr/lib/xorg/modules/drivers/radeon_drv.so
(II) Loading /usr/lib/xorg/modules/drivers/ati_drv.so
(II) Reloading /usr/lib/xorg/modules/drivers/radeon_drv.so
(III) Desktop is: GNOME
(IV) libgcj version is: libgcj-4.1.1-14-i386
(V) kernel is: Linux 2.6.17-1.2528.fc6 #1 SMP Sun Aug 6 01:43:42 EDT 2006 i686
i686 i386
(VI) OpenOffice.org core rpm version is: openoffice.org-core-2.0.3-7.8-i386
(VII) accessibility is: false
(VIII) fedora release is: Fedora Core release 5.91 (FC6 Test2)
...start sestatus details ...
SELinux status:                 disabled
...end sestatus details ..
Comment 2 Caolan McNamara 2006-08-08 09:44:02 EDT

*** This bug has been marked as a duplicate of 201546 ***

Note You need to log in before you can comment on or make changes to this bug.