Bug 201746 - Kernel Panic after installation
Kernel Panic after installation
Status: CLOSED DUPLICATE of bug 196360
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
6
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-08 13:59 EDT by Herbert Straub
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-16 17:11:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Console screenshot with the error message (80.24 KB, image/png)
2006-08-08 13:59 EDT, Herbert Straub
no flags Details

  None (edit)
Description Herbert Straub 2006-08-08 13:59:49 EDT
Description of problem:

I cannot boot the system after a fresh installation of Fedora Core 6 Test 2 on a
HP Blade server via Firefox and ILO Java Console, because: could not find root
filesystem. I find no way to copy the console output to ASCII text, therefore i
attached the console output as PNG screenshot.

My workaround to boot the system:
1. Change the Grub Kernel line from ... root=LABEL=/12 ... to ...
root=/dev/cciss/c0d0p1 single

2. Edit /etc/fstab and change:
#LABEL=/12               /                       ext3    defaults        1 1
/dev/cciss/c0d0p1               /                       ext3    defaults        

#LABEL=SW-cciss/c0d0p5   swap                    swap    defaults        0 0
/dev/cciss/c0d0p5   swap                    swap    defaults        0 0

reboot. Looks OK

Blkid:
[root@localhost ~]# blkid
/dev/cciss/c0d0p1: LABEL="/12" UUID="49e2d117-0c2f-4a46-ba72-03307dd32931"
SEC_TYPE="ext2" TYPE="ext3"
/dev/cciss/c0d0p2: LABEL="/1" UUID="33fca6cb-629e-435d-b677-7c21d48ff8d6"
SEC_TYPE="ext2" TYPE="ext3"
/dev/cciss/c0d0p3: LABEL="/" UUID="d55bc382-2f61-4adf-9740-925457e2d199"
SEC_TYPE="ext2" TYPE="ext3"
/dev/cciss/c0d0p5: LABEL="SW-cciss/c0d0p5" TYPE="swap"
/dev/cciss/c0d0p7: UUID="e60cd4d8-3909-4264-acfc-c47459c4c502" SEC_TYPE="ext2"
TYPE="ext3"
/dev/cciss/c0d0p8: UUID="24bd8402-3e2f-4f0b-9730-3e416f0804d6" SEC_TYPE="ext2"
TYPE="ext3"

root@localhost ~]# uname -a
Linux localhost.localdomain 2.6.17-1.2517.fc6 #1 SMP Thu Aug 3 05:00:49 EDT 2006
x86_64 x86_64 x86_64 GNU/Linux


Regards
Herbert Straub
Comment 1 Herbert Straub 2006-08-08 13:59:51 EDT
Created attachment 133813 [details]
Console screenshot with the error message
Comment 2 Dave Jones 2006-08-11 01:53:36 EDT
Looks like a broken initrd.  Peter, any ideas?
Comment 3 Peter Jones 2006-08-16 16:54:20 EDT
Yeah, cciss uses '!' at a very unfortunate place, and everything else in sysfs
uses '!' to mean something else.  I'll have to spend some time with a cciss card
soon and fix this :/
Comment 4 Peter Jones 2006-08-16 17:11:47 EDT

*** This bug has been marked as a duplicate of 196360 ***

Note You need to log in before you can comment on or make changes to this bug.