Bug 201808 - request for package in extras: aria2 (command line BitTorrent client)
request for package in extras: aria2 (command line BitTorrent client)
Status: CLOSED DUPLICATE of bug 221039
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Thorsten Leemhuis (ignored mailbox)
Fedora Package Reviews List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-08 19:13 EDT by Ant Bryan
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-19 10:52:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ant Bryan 2006-08-08 19:13:53 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b1) Gecko/20060808 BonEcho/2.0b1

Description of problem:
This is a request that you will include aria2 (http://aria2.sourceforge.net/) RPMs in Fedora Extras. aria2 is a command line download utility that supports BitTorrent. It's like the aria2 download manager but light weight and no GUI.

I've been using this .spec file to package it, but I don't really know what I'm doing.

%define ver 0.7.0
%define rel 1.FC6
%define prefix /usr
Name        : aria2
Version     : %{ver}                           
Source      : aria2-%{ver}.tar.bz2
Release     : %{rel}                          
Group       : Productivity/Networking
License     : GPL
Packager    : Anthony Bryan <anthonybryan@gmail.com>
URL         : http://aria2.sourceforge.net/
Summary     : aria2 is a download utility with BitTorrent and Metalink support.
BuildRoot:       %{_tmppath}/%{name}-buildroot
BuildRequires:  openssl-devel  libxml2-devel

%description
aria2 is a download utility with resuming and segmented downloading.
Supported protocols are HTTP/HTTPS/FTP/BitTorrent/Metalink.


%prep
rm -rf $RPM_BUILD_ROOT  
%setup
 
%build
CFLAGS="$RPM_OPT_FLAGS" ./configure \
                --mandir=%{_mandir} \
                --prefix=%{prefix}

%{__make} %{?_smp_mflags}

%install
[ "$RPM_BUILD_ROOT" != "/" ] && [ -d $RPM_BUILD_ROOT ] && rm -rf $RPM_BUILD_ROOT;
make DESTDIR=$RPM_BUILD_ROOT install

%clean
rm -rf $RPM_BUILD_ROOT
  
%files
%defattr(-, root, root, 0755)
%doc ChangeLog COPYING NEWS README AUTHORS TODO
#%{_libdir}/*.so.*
#%doc doc/API.html doc/DOCUMENTATION doc/README.html
%{_bindir}/*
#%{_includedir}/libetpan/
#%{_includedir}/libetpan.h
#%exclude %{_libdir}/*.a
#%exclude %{_libdir}/*.la
#%{_libdir}/*.so
/usr/share/locale/*

%changelog
 * Tue Aug 8 2006 Anthony Bryan <anthonybryan@gmail.com>
 - Update to version 0.7.0

 * Fri Jul 28 2006 Anthony Bryan <anthonybryan@gmail.com>
 - Update to version 0.6.0+1 and FC6
 
 * Mon Jun 5 2006 Malcolm A Hussain-Gambles <malcolm@secpay7.force9.co.uk>
 - First release of this package by me


Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1. No packages included

Actual Results:


Expected Results:


Additional info:
Comment 1 Paul Howarth 2006-08-09 06:01:21 EDT
If you're interested in developing this package so as to meet the Fedora
Packaging Guidelines and to maintain it yourself in Extras, you should read:

http://fedoraproject.org/wiki/Extras/Contributors
http://fedoraproject.org/wiki/Packaging/Guidelines

If not, it would be better to add it here:

http://fedoraproject.org/wiki/Extras/WishList

in the hope that someone will pick up the package and maintain it in Extras
themselves.
Comment 2 Mamoru TASAKA 2007-01-19 10:52:35 EST

*** This bug has been marked as a duplicate of 221039 ***

Note You need to log in before you can comment on or make changes to this bug.