Bug 201851 - wmacpi don't change when on battery
wmacpi don't change when on battery
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: wmacpi (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
:
Depends On: 222072
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-09 10:02 EDT by Patrice Dumas
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.2-0.1.a1.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-07 04:04:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
specfile patch to update to latest version (2.32 KB, patch)
2007-01-09 19:28 EST, Patrice Dumas
no flags Details | Diff
initialize properly libdockapp (803 bytes, patch)
2007-01-09 19:29 EST, Patrice Dumas
no flags Details | Diff

  None (edit)
Description Patrice Dumas 2006-08-09 10:02:49 EDT
Description of problem:
wmacpi doesn't change when on battery. I use wmacpi with fluxbox.
acpitool output is
$ acpitool 
  Battery #1     : discharging, 92.39%, 02:12:06
  AC adapter     : off-line
  Thermal zone 1 : ok, 40 C
but wmacpi is still on ac power with 100%

I have a dell latitude d505 with acpi

Version-Release number of selected component (if applicable):
wmacpi-1.34-6.fc5


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Patrice Dumas 2006-10-15 09:29:06 EDT
I found today that the wmacpi version shipped in fedora is very old
(2002) and that development is now done at another place:

http://himi.org/wmacpi/

with latest version released in 2005. So having wmacpi not working isn't
a big surprise.
Comment 2 Patrice Dumas 2007-01-09 19:27:16 EST
I have a modified spec file (and a patch) for the new version, 
which works. It depends on libdockapp I have just submitted.
Comment 3 Patrice Dumas 2007-01-09 19:28:47 EST
Created attachment 145210 [details]
specfile patch to update to latest version
Comment 4 Patrice Dumas 2007-01-09 19:29:58 EST
Created attachment 145211 [details]
initialize properly libdockapp
Comment 5 Patrice Dumas 2007-01-10 05:17:08 EST
libdockapp is now in devel. I can update and rebuild wmacpi in the
devel branch and in the other branches whenever libdockapp appears
in thoses branches.
Comment 6 Patrice Dumas 2007-01-10 08:08:40 EST
Upstream has integrated the patch in 2.2a1.
Comment 7 Patrice Dumas 2007-01-22 10:09:45 EST
I consider the issue to be harmful since it prevents wmacpi to work.
No need to hurry, however since it has been broken for months.
As per the 'Who can modify packages guideline', I will let you 14 
days to fix it and afterwards I'll fix it myself (change cvs in devel,
wait 2 days, build, change cvs in branches, wait 2 days, build).
Comment 8 Andreas Bierfert 2007-01-22 16:35:33 EST
Hm missed the devel announcement as I was sick for some time now. Will upgrade
asap (tomorrow).
Comment 9 Patrice Dumas 2007-01-31 19:36:24 EST
Everything seems right now, thanks, you can close the bug.
Comment 10 Andreas Bierfert 2007-02-07 04:04:47 EST
Thanks for reporting.

Note You need to log in before you can comment on or make changes to this bug.