Bug 201857 - gnome-screensaver lock dialog shouldn't assume what PAM will tell it to do
gnome-screensaver lock dialog shouldn't assume what PAM will tell it to do
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnome-screensaver (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
: Reopened
Depends On:
Blocks: FC6Update
  Show dependency treegraph
 
Reported: 2006-08-09 10:41 EDT by Ray Strode [halfline]
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-29 10:33:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
hide and show various UI elements depending on what PAM is asking for, process pam conversation in a thread (18.96 KB, patch)
2006-10-02 00:08 EDT, Ray Strode [halfline]
no flags Details | Diff

  None (edit)
Description Ray Strode [halfline] 2006-08-09 10:41:24 EDT
Right now gnome-screensaver's lock dialog starts up with a prompt of "Password:
" hardcoded, and the entry fields visible and enabled.

It's possible that PAM will ask for something else instead of "Password: " so
this causes confusing changing messages in those cases.  

Also, it's possible that pam won't prompt for any keyboard input at all, but
instead display a message to the user like "Please insert smart card".

The entry should either be hidden by default or disabled by default.
Comment 1 jmccann 2006-08-09 10:47:08 EDT
Yeah, this was a conscious decision.  It is to support typing before the dialog
comes up.
Comment 2 Ray Strode [halfline] 2006-08-09 10:59:39 EDT
ah that makes sense.

Well, maybe we can do something like realize the entry but not show it until pam
asks for input.
Comment 4 Orla Hegarty 2006-09-15 16:22:56 EDT
*** This bug has been marked as a duplicate of 201878 ***

*** This bug has been marked as a duplicate of 201878 ***
Comment 5 Ray Strode [halfline] 2006-10-01 23:38:01 EDT
Not sure why this bug got, closed...reopened now.
Comment 6 Ray Strode [halfline] 2006-10-02 00:08:32 EDT
Created attachment 137520 [details]
hide and show various UI elements depending on what PAM is asking for, process pam conversation in a thread

So I commited the above to rawhide.  It hides the entry by default, but
attempts to doing key queueing on the plug side like the socket side does.

The key queuing doesn't work though--the first few characters don't get
through. 

The patch also punts PAM processesing to a thread, so that the "Cancel" button
responds even while the PAM modules is blocked doing network I/O or waiting for
the user to insert a smart card.

Note You need to log in before you can comment on or make changes to this bug.