Bug 20198 - Errors Displayed at the end on istallation. System will not boot.
Errors Displayed at the end on istallation. System will not boot.
Status: CLOSED DUPLICATE of bug 18031
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0J
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-02 06:06 EST by Need Real Name
Modified: 2007-04-18 12:29 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-03 15:03:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda Dump (1018 bytes, text/plain)
2000-11-02 06:07 EST, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2000-11-02 06:06:17 EST
Installed using anaconda update disk. 

Installation seems to proceed normally right through to the very end when 
the information below is displayed. The system will not boot.

This system was running fine on RedHat 6.2 until I tried to upgrade to 7.0 
and the upgrade crashed.

Traceback (innermost last):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", 
line 20, in run
    rc = self.todo.doInstall ()
  File "/tmp/updates/todo.py", line 1651, in doInstall
    self.writeConfiguration ()
  File "/tmp/updates/todo.py", line 1402, in writeConfiguration
    self.writeRootPassword ()
  File "/tmp/updates/todo.py", line 660, in writeRootPassword
    self.setPassword("root", pure)
  File "/tmp/updates/todo.py", line 1151, in setPassword
    stdin = p[0], stdout = devnull)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iutil.py", line 40, in 
execWithRedirect
    raise RuntimeError, command + " can not be run"
RuntimeError: /usr/bin/passwd can not be run

Local variables in innermost frame:
argv: ['/usr/bin/passwd', '--stdin', 'root']
root: /mnt/sysimage
stdin: 23
newPgrp: 0
stdout: 22
stderr: 2
command: /usr/bin/passwd
searchPath: 0
ignoreTermSigs: 0

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>
Comment 1 Need Real Name 2000-11-02 06:07:38 EST
Created attachment 4914 [details]
Anaconda Dump
Comment 2 Michael Fulbright 2000-11-03 15:03:47 EST
There was a problem installing the package which containged the passwd command. 
If you burned your own CD you may want to try again, it appears there could have
been an error with the current CD.

*** This bug has been marked as a duplicate of 18031 ***

Note You need to log in before you can comment on or make changes to this bug.