This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 201991 - useradd can't find group
useradd can't find group
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: shadow-utils (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Vrabec
David Lawrence
: Reopened
: 201993 (view as bug list)
Depends On:
Blocks: FC6Blocker
  Show dependency treegraph
 
Reported: 2006-08-10 04:23 EDT by Karsten Hopp
Modified: 2016-07-29 06:44 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-11 07:00:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karsten Hopp 2006-08-10 04:23:01 EDT
Description of problem:
I found this in cron/anacron's logs:
/etc/cron.daily/beagle-crawl-system:
chown: `beaglidx': invalid user

/etc/passwd has no entry for beaglidx

Version-Release number of selected component (if applicable):
beagle-0.2.7-6
setup-2.5.53-1
Comment 1 Karsten Hopp 2006-08-10 04:28:18 EDT
As this was a fresh install there are more infos in install.log:
Installing beagle - 0.2.7-6.x86_64
warning: user beaglidx does not exist - using root
warning: user beaglidx does not exist - using root

This looks like a missing Requires(pre): shadow-utils as shadow-utils is installed
much later than beagle
Comment 2 Alexander Larsson 2006-08-10 10:50:29 EDT
0.2.7-7 adds the prereq.
Comment 3 Alexander Larsson 2006-08-10 12:14:58 EDT
That didn't help. Seems to be a useradd bug:

/usr/sbin/groupadd -g 1000 blah
/usr/sbin/useradd -r -u 1000 -s /sbin/nologin -c "blah" -d / -g 1000 blah
useradd: unknown group 1000

This doesn't happen in fc5.
Comment 4 Alexander Larsson 2006-08-10 12:20:23 EDT
Using -g blah gives:
useradd: "invalid numeric argument 'blah'

Note, the groupadd works. The problem is in useradd.
Comment 5 Wart 2006-08-10 19:37:00 EDT
For reference:  shadow-utils-4.0.17-4 in rawhide is affected by this bug.
Comment 6 Peter Vrabec 2006-08-11 07:00:20 EDT
fixed in shadow-utils-4.0.17-5
Comment 7 Martin Stransky 2006-08-17 06:53:03 EDT
*** Bug 201993 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.