Bug 201993 - error: named:3 unknown user 'named'
error: named:3 unknown user 'named'
Status: CLOSED DUPLICATE of bug 201991
Product: Fedora
Classification: Fedora
Component: bind (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-10 04:41 EDT by Karsten Hopp
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-17 06:53:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Karsten Hopp 2006-08-10 04:41:25 EDT
Description of problem:
I found this in crond's log:
/etc/cron.daily/logrotate:
error: named:3 unknown user 'named'

This was a fresh install (x86_64) and install.log has these lines:
Installing bind - 30:9.3.2-34.fc6.x86_64
warning: user named does not exist - using root
warning: user named does not exist - using root
warning: user named does not exist - using root
Installing bind-config - 30:9.3.2-34.fc6.x86_64
/bin/chown: `named:named': invalid user
/bin/chown: `named:named': invalid user

According to install.log shadow-utils is already installed when bind gets
installed, so this should be ok.


Further checking shows that bind has Requires(pre): shadow-utils sinc March,
so I'm not sure what is going on here.
Comment 1 Martin Stransky 2006-08-11 04:20:54 EDT
We check the fresh install here and it looks fine:

install.log:

Installing initscripts-8.31.1-1.x86_64.
Installing bind-9.3.2-4.1.x86_64.
Installing vixie-cron-4.1-54.FC5.x86_64.

install.log.syslog:

<86>Aug 10 09:46:08 groupadd[1059]: new group: name=named, GID=25
<86>Aug 10 09:46:09 useradd[1060]: new user: name=named, UID=25, GID=25,
home=/var/named, shell=/sbin/nologin

and bind works fine....
Comment 2 Martin Stransky 2006-08-11 04:24:08 EDT
Oops, you may be right because we updated from FC5 to rawhide..
Comment 3 Karsten Hopp 2006-08-11 04:46:52 EDT
I didn't check the specfile again, but could this be related to another bug I've
filed which points at a shadow-utils bug ?   That's bug #201991
Comment 4 Martin Stransky 2006-08-11 04:56:32 EDT
okay, I'll check this bug
Comment 5 Martin Stransky 2006-08-11 05:04:23 EDT
Yes, it looks like a dupe of Bug 201991, peter is working on it.
Comment 6 Martin Stransky 2006-08-17 06:53:00 EDT

*** This bug has been marked as a duplicate of 201991 ***

Note You need to log in before you can comment on or make changes to this bug.