Bug 202034 - devhelp uninstallable with new seamonkey update
devhelp uninstallable with new seamonkey update
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: devhelp (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
:
: 205120 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-10 10:36 EDT by Bastien Nocera
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version: devhelp-0.10-0.8.el4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-01 12:20:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bastien Nocera 2006-08-10 10:36:16 EDT
devhelp-0.10-0.2.el4

1. Install RHEL4U3
2. Make sure devhelp is installed
3. Try to up2date:
 Unresolvable chain of dependencies:
 devhelp-0.10-0.2.el4                     requires mozilla = 37:1.8

But mozilla is deprecated in favour of seamonkey
devhelp needs to be updated to mention seamonkey, and rebuilt.
Comment 3 Jay Turner 2006-08-11 08:48:22 EDT
Bastian, sounds like something else is going on with your system, as
seamonkey-1.0.3-0.el4.1 provides "mozilla = 37:1.8"  Are you updating against
the live RHN site or from another source?
Comment 4 Bryn M. Reeves 2006-09-04 15:26:18 EDT
*** Bug 205120 has been marked as a duplicate of this bug. ***
Comment 5 Bryn M. Reeves 2006-09-04 15:43:36 EDT
devhelp.spec has BuildRequires for mozilla and mozilla-devel >= 1.6

Looks like mozilla-1.7.13 was in the buildroots when the package was built:

# LD_LIBRARY_PATH=/usr/lib/mozilla-seamonkey-1.0.3/ devhelp
devhelp: symbol lookup error: /usr/lib/libdevhelp-1.so.0: undefined symbol:
_ZTV24nsGetServiceByContractID

devhelp-0.10-0.2.el4 clearly contains a reference to the old mozilla suite
shared lib:

# ldd /usr/lib/libdevhelp-1.so.0 | grep gtkembed
        libgtkembedmoz.so => not found

# readelf -a /usr/bin/devhelp | grep moz
 0x00000001 (NEEDED)                     Shared library: [libgtkembedmoz.so]
 0x0000000f (RPATH)                      Library rpath: [/usr/lib/mozilla-1.7.13]

Note You need to log in before you can comment on or make changes to this bug.