Note: This bug is displayed in read-only format because the product is no longer active in Red Hat Bugzilla.

Bug 2020378

Summary: e2e-aws-upi is failing with "Invalid value: []string{"us-west-2d", "us-west-2b"}: No subnets provided for zones"
Product: OpenShift Container Platform Reporter: Stephen Benjamin <stbenjam>
Component: Test FrameworkAssignee: Devan Goodwin <dgoodwin>
Status: CLOSED DUPLICATE QA Contact:
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 4.9   
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2021-11-05 13:15:23 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Stephen Benjamin 2021-11-04 17:20:55 UTC
This bug was initially created as a copy of Bug #1991730. This error has started coming up again in the e2e-aws-upi jobs:

level=fatal msg=failed to fetch Master Machines: failed to load asset "Install Config": [controlPlane.platform.aws.zones: Invalid value: []string{"us-west-1a", "us-west-1b", "us-west-1c"}: No subnets provided for zones [us-west-1c], compute[0].platform.aws.zones: Invalid value: []string{"us-west-1a", "us-west-1b", "us-west-1c"}: No subnets provided for zones [us-west-1c]] 


Example job:
https://prow.ci.openshift.org/view/gcs/origin-ci-test/logs/release-openshift-ocp-installer-e2e-aws-upi-4.10/1456053704313540608

Comment 2 Stephen Benjamin 2021-11-05 13:15:23 UTC

*** This bug has been marked as a duplicate of bug 2020622 ***