Bug 202137 - WLan works with kernel 2.6.15 but not with 2.6.17
WLan works with kernel 2.6.15 but not with 2.6.17
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: John W. Linville
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-10 19:37 EDT by Roland Wolters
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-11 18:59:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
An example of a working WLan session with kernel 2.6.15 (20.18 KB, text/plain)
2006-08-10 19:37 EDT, Roland Wolters
no flags Details
An example of a non-working WLan session with kernel 2.6.17: first time it dies away, second time it does not connect at all (35.33 KB, text/plain)
2006-08-10 19:38 EDT, Roland Wolters
no flags Details
demsg output (18.25 KB, text/plain)
2006-08-14 14:58 EDT, Roland Wolters
no flags Details
the dmesg output, produced short after trying to access the WLan (20.81 KB, text/plain)
2006-11-03 15:47 EST, Roland Wolters
no flags Details
messages output of a failed wlan access attempt (4.01 KB, text/plain)
2006-11-03 15:48 EST, Roland Wolters
no flags Details
relevant /var/log/messages part (2.56 KB, text/plain)
2006-12-21 16:12 EST, Roland Wolters
no flags Details
dmesg output (21.61 KB, text/plain)
2006-12-21 16:14 EST, Roland Wolters
no flags Details

  None (edit)
Description Roland Wolters 2006-08-10 19:37:25 EDT
Description of problem:
I cannot connect properly to a wireless LAN with the 2.6.17 kernel. It works 
with the 2.6.15 without any problems, though.
Properly means, that most times the connections fails, I do not get an IP with 
dhcp. Very seldom, the connection with 2.6.17 kernels works, but only for some 
seconds - after that I cannot ping the router any more although in these cases 
I do not get any error message.

System information:
The WLan card is a ipw2200 pro. The firmware is installed with the packages 
from livna. It also does not work when I get the firmware from the ipw2200 
homepage.
I tried this with several different WLan access points, at least one of them 
WEP encrypted, the others not encrypted at all.
The user space program I use is the NetworkManager, but I also tried by hand 
with iwconfig. This failed also.
I tested other WLan cards which showed the same problem with kernel 2.6.17. 
But these two cards were both driven by ndiswrapper, and I never tested them 
with kernel 2.6.15.

Version-Release number of selected component (if applicable):
kernel-2.6.17.2174 does not work at all, kernel-2.6.15-1.2054 works. The 
ip2200 package has the number ipw2200-firmware-3.0-1.

How reproducible:
Take a WLan enabled computer and try to connect to a WLan.

Additional info:
I attach two text files with /var/log/messages outputs:
The first, wlan-working is the output of a session with the 2.6.15 kernel. The 
second is an output of a 2.6.17 kernel: it worked in the first moment for some 
seconds. After it died away (without any disconnection message!) I reconnected 
(in the log mentioned as user switch), but this time it was not even able to 
get an IP.
Comment 1 Roland Wolters 2006-08-10 19:37:25 EDT
Created attachment 133997 [details]
An example of a working WLan session with kernel 2.6.15
Comment 2 Roland Wolters 2006-08-10 19:38:46 EDT
Created attachment 134000 [details]
An example of a non-working WLan session with kernel 2.6.17: first time it dies away, second time it does not connect at all
Comment 3 John W. Linville 2006-08-11 10:34:45 EDT
Please attach the output from running dmesg soon after trying to use the 
ipw2200 driver on 2.6.17...thanks!
Comment 4 Roland Wolters 2006-08-14 14:58:38 EDT
Created attachment 134160 [details]
demsg output

As I said, this time it was a WAP secured network where I did not had a valid
key.
Comment 5 Dave Jones 2006-10-16 17:46:01 EDT
A new kernel update has been released (Version: 2.6.18-1.2200.fc5)
based upon a new upstream kernel release.

Please retest against this new kernel, as a large number of patches
go into each upstream release, possibly including changes that
may address this problem.

This bug has been placed in NEEDINFO state.
Due to the large volume of inactive bugs in bugzilla, if this bug is
still in this state in two weeks time, it will be closed.

Should this bug still be relevant after this period, the reporter
can reopen the bug at any time. Any other users on the Cc: list
of this bug can request that the bug be reopened by adding a
comment to the bug.

In the last few updates, some users upgrading from FC4->FC5
have reported that installing a kernel update has left their
systems unbootable. If you have been affected by this problem
please check you only have one version of device-mapper & lvm2
installed.  See bug 207474 for further details.

If this bug is a problem preventing you from installing the
release this version is filed against, please see bug 169613.

If this bug has been fixed, but you are now experiencing a different
problem, please file a separate bug for the new problem.

Thank you.
Comment 6 Roland Wolters 2006-11-03 15:47:33 EST
Created attachment 140314 [details]
the dmesg output, produced short after trying to access the WLan
Comment 7 Roland Wolters 2006-11-03 15:48:31 EST
Created attachment 140315 [details]
messages output of a failed wlan access attempt
Comment 8 John W. Linville 2006-11-03 15:55:01 EST
Do you have the version 3.0 ipw2200 firmware available in /lib/firmware?

If not, please install there it after obtaining it from here:

   http://ipw2200.sourceforge.net/firmware.php

Does the latest firmware help?
Comment 9 Roland Wolters 2006-11-03 16:44:54 EST
Thanks for the quick answer - unfortunatelly it didn't work. I tested with the 
freshrpms package, but also with the original firmware.
Comment 10 John W. Linville 2006-12-12 10:25:41 EST
Your wireless network doesn't look too complicated (judging from the 
NetworkManager messages in the dmesg).  Have you tried without using 
NetworkManager?

   # service NetworkManager stop
   # ifconfig eth1 up
   # iwconfig eth1 essid ConnectionPoint
   # dhclient eth1

Does that bring-up the device and get an IP address?
Comment 11 Roland Wolters 2006-12-21 16:12:30 EST
Created attachment 144219 [details]
relevant /var/log/messages part
Comment 12 Roland Wolters 2006-12-21 16:14:41 EST
Created attachment 144222 [details]
dmesg output

Manual configuring the device does not work, see the dmesg and the messages
output. :/
Comment 13 Roland Wolters 2006-12-22 16:31:04 EST
I used the grml live CDs to check if I can still access the WLan with a kernel 
2.6.15 - and I was able to verify it:
There were no problems at all with grml 0.6 (kernel 2.6.15) but I was not able 
to access the WLan with grml 0.9 (kernel 2.6.18). I can post the dmesg and 
messages outputs or test against other grml versions.
That was with manual configuration, grml does not come with NetworkManager.

I would install the kernel 2.6.15 from fc5 but it does not work because of a 
hal dependency :/
Comment 14 Roland Wolters 2006-12-29 08:42:41 EST
If I can provide any debug information just post me how to do that, I would 
love to provide more information.
Comment 15 Roland Wolters 2007-02-09 10:14:41 EST
Fyi: the problem is still valid in Kernel 2.6.19-1.2895.fc6
Also, I now bought a D-Link WLan router so I can set up any test environment 
at any time. Just say what information I should provide, and I will do (if 
anything comes to your mind, looks like I'm the only one with that problem).
Comment 16 Roland Wolters 2007-02-11 16:00:47 EST
Today I tried to reproduce the problem with the OpenSuse 10.2 Live DVD - and 
there the WLan worked. The Opensuse Live DVD uses a kernel of the 2.6.18 line.
Comment 17 Roland Wolters 2007-02-11 18:59:41 EST
It magically started working - magically, because I have no idea why it 
suddenly does so. However, just in case anyone else ever comes into the same 
situation, here is what I did:

I tried to set up the wireless connection with wifi-radar. I expected it to 
fail (since I've also tried other programs, tools and the command line) and so 
did it. The dhcp client was unable to receive a response.
However, in wifi-radar you can also, if you want to, set some values for the 
connection, and so I set the right channel (6) - and it worked. It connected 
and everything.

After that I also set the channel in system-config-network to 6 - and suddenly 
NetworkManager was able to connect.
But afterwards I also set the channel in system-config-network to other 
values, or the mode to managed (where you cannot set any channel at all), and 
every configuration I tried worked this time.

So, after all, I have no idea why it suddenly works. And I have no idea why 
for example grml struggled to connect to the WLan with the newer kernel.
But I would like to thank everyone who has looked into this and spent time 
thinking about it. I myself spent much to many hours on this problem, what a 
waste :/

Note You need to log in before you can comment on or make changes to this bug.