Bug 202139 - Failure to boot on non-PAE hardware
Failure to boot on non-PAE hardware
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel-xen (Show other bugs)
6
All Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Brian Brock
:
: 202187 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-10 19:56 EDT by Adam Huffman
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-25 17:01:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Huffman 2006-08-10 19:56:41 EDT
Description of problem:
The kernel installed on a Vaio S1XP laptop does not boot, because the CPU has no
PAE support.  Perhaps anaconda should check whether the CPU has this support
before offering Xen as an option?  After I saw the message I vaguely remembered
a discussion of this on one of the mailing lists, but couldn't remember how it
was resolved.

Version-Release number of selected component (if applicable):


How reproducible:
Every time

Steps to Reproduce:
1. Boot laptop
2.
3.
  
Actual results:
Kernel panics with a message about not being able to boot a PAE kernel on a
non-PAE CPU.

Expected results:
Kernel boots

Additional info:

The CPU is a Pentium M 1.7GHz

I have filed the bug against kernel-xen for the moment, though as I indicated
earlier, either this problem should be alluded to in the release notes (which
were blank) or anaconda should refuse to install Xen on such hardware.
Comment 1 Brian Stein 2006-08-11 10:26:03 EDT
*** Bug 202187 has been marked as a duplicate of this bug. ***
Comment 2 Jeremy Katz 2006-09-25 17:01:08 EDT
anaconda doesn't allow you to install Xen on pae-less hardware now

Note You need to log in before you can comment on or make changes to this bug.