Bug 202187 - xenguest-install fails on host running kernel-xen with PAE
xenguest-install fails on host running kernel-xen with PAE
Status: CLOSED DUPLICATE of bug 202139
Product: Fedora
Classification: Fedora
Component: xen (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Xen Maintainance List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-11 09:59 EDT by Edouard Bourguignon
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-11 10:25:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Edouard Bourguignon 2006-08-11 09:59:21 EDT
Description of problem:

In xenguest_install.py the function get_paravirt_install_image() try to grab
images/xen/vmlinuz to start the install in the guest OS. But it fails on xen
(dom0) with PAE support, certainly because this images/xen/vmlinuz (needed by
the domU to boot the install process from the repository) doesn't support PAE.

Steps to Reproduce:
1. install and boot on kernel-xen (for PAE support on host with more than 4G of ram)
2. try to run a guest install using installguest-install.py

  
Actual results:

+ exit 1
ERROR: Non PAE-kernel on PAE host.
ERROR: Error constructing guest OS
Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/xen/xend/server/SrvDomainDir.py", line
77, in op_create
    dominfo = self.xd.domain_create(config)
  File "/usr/lib/python2.4/site-packages/xen/xend/XendDomain.py", line 228, in
domain_create
    dominfo = XendDomainInfo.create(config)
  File "/usr/lib/python2.4/site-packages/xen/xend/XendDomainInfo.py", line 190,
in create
    vm.initDomain()
  File "/usr/lib/python2.4/site-packages/xen/xend/XendDomainInfo.py", line 1311,
in initDomain
    raise VmError(str(exn))
VmError: (9, 'Bad file descriptor')

Expected results:

xenguest-install.py should grabb a xen kernel image with PAE support for
installing guest on host runing kernel-xen with PAE.

Additional info:

Both Xen kernel images (with and without PAE) should be present in repositories
and cdroms.
Is there a way to rebuild this xen kernel image to support PAE?
Comment 1 Brian Stein 2006-08-11 10:25:46 EDT

*** This bug has been marked as a duplicate of 202139 ***

Note You need to log in before you can comment on or make changes to this bug.