Bug 20217 - File "/usr/bin/anaconda.real", line 438 in ?
File "/usr/bin/anaconda.real", line 438 in ?
Status: CLOSED DUPLICATE of bug 18019
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-02 10:51 EST by Ravi S. Kasarla
Modified: 2007-04-18 12:29 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-03 15:01:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ravi S. Kasarla 2000-11-02 10:51:08 EST
02-NOV-2000 5:00AM
Installing Linux 7.0 from hard disk, down loaded RPMS and base from 
ftp.redhat.com/pub/redhat/RedHat/redhat-7.0/en/i386...

Used rawwrite and put boot.img on floppy and started the install...



Linux 7.0 install failed with the following Exception:

Exception Occurred

An internal error occurred in the installation program.  
Please report this error to Red Hat (through the
bugzilla.redhat.com web site) as soon as possible.

Traceback (innermost last):

File "/usr/bin/anaconda.real", line 438 in ?
   intf.run (todo, test = test)


Possible Bug Number: 17889

Traceback (innermost last):
  File "/usr/bin/anaconda.real", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, in 
run
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/textw/packages_text.py", 
line 33, in __call__
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 539, in 
getCompsList
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/harddrive.py", line 43, 
in readComps
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 459, in 
__init__
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 428, in 
readCompsFile
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 101, in 
__getitem__
KeyError: apmd

Local variables in innermost frame:
self: <comps.HeaderList instance at 82fa218>
item: apmd

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iharddrive
HardDriveInstallMethod
p4
(dp5
S'fstype'
p6
S'vfat'
p7
sS'isMounted'
p8
I1
sS'fnames'
p9
(dp10

<failed>
Comment 1 Ravi S. Kasarla 2000-11-03 09:33:05 EST
I FTPed an ISO image burned on CD and could successfully install RedHat 7.0 on the same machine.
Comment 2 Michael Fulbright 2000-11-03 15:01:54 EST
The original problem was due to a corrupt hard drive install image.

*** This bug has been marked as a duplicate of 18019 ***
Comment 3 Need Real Name 2001-02-14 23:30:10 EST
I too had the same problem which i spent 2 days on. It turned out to be a bad 
CD. I tried to copy the software to my drive to do a "hard disk" install, and 
thats when I found one of the base image files wasnt getting copied off the CD 
completely. I found the 'truncated' file, ftp'd it down from redhat, and it 
then worked like a charm!!! Its a pity that the redhat error couldnt have been 
more helpful. It could have made it an easy 30 minute fix rather than 2 days.

Note You need to log in before you can comment on or make changes to this bug.