Bug 202299 - Firefox closes after 13 seconds with flash plugin
Firefox closes after 13 seconds with flash plugin
Status: CLOSED DUPLICATE of bug 155582
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-12 09:08 EDT by Alex Grim
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-10 15:33:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alex Grim 2006-08-12 09:08:01 EDT
Description of problem:
Once the flash-plugin is installed, firefox becomes highly unstable, and will
crash at most 13 seconds after it is opened. By 'crash' i mean unload
completely. I'm sorry if this is not detailed enough, i have just switched from
micro$oft to linux, so i do not not what else to look for.


Version-Release number of selected component (if applicable):
I'm using Fedora Core 6 Test Release 2. I do have all the latest updates as of,
well, every day.


Steps to Reproduce:
1. Install 'flash-plugin' from this repo:
http://macromedia.mplug.org/rpm
2. Happy crashing.
  

Actual results:
Firefox unloads from memory completely after being loaded for a few seconds.
Sometimes, as soon as you tell it whether or not you want to resume your crashed
session, it closes.


Expected results:
I don't think this applies here...

Additional info:
Yeah, like i said, i'm new, so i don't know where the 'event veiwer' is for
linux. Sorry.
Comment 1 Minju, Lee 2006-08-15 00:03:11 EDT
The program 'Gecko' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadMatch (invalid parameter attributes)'.
  (Details: serial 150 error_code 8 request_code 146 minor_code 3)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
Comment 2 Warren Togami 2006-08-16 19:52:05 EDT
killall firefox-bin
export XLIB_SKIP_ARGB_VISUALS=1
firefox

Does this make it not crash?  If so then this is a duplicate of Bug #155582
Comment 3 Jong Bae KO 2006-08-16 19:54:05 EDT
RHEL5-Server-20060810.0 has the same problem too.

kernel-2.6.17-1.2519.el5
firefox-1.5.0.5-8
Comment 4 Warren Togami 2006-08-16 19:59:55 EDT
Note that due to Bug #155582, Bug #184028, and sometimes Bug #189622, the
current version of flash is pretty much unusable on Linux.  Adobe is supposed to
be releasing a beta of Flash 9 for Linux soon that should correct these issues.
Comment 5 David Cartwright 2006-08-20 03:15:13 EDT
For reference, I have installed FC6 Test 2 and ran yum update as of August 20.

When visiting a site requiring Macromedia Flash I installed the required Flash
plugin. The site re-displayed with the Flash page.

However at a later time when opening Gmail, the browser closed immediately after
displaying all the messages.

I deleted the Flash plugin and then tried the Flash RPM from
http://macromedia.mplug.org/rpm.

However the result was exactly the same with Firefox closing as soon as Gmail
reached the point of displaying emails.

Under FC5, I didn't have these problems when opening Gmail or other Flash sites,
although I was certainly seeing some occasional system lock-ups that seem
related to times when I used either Firefox or Thunderbird (that both use the
Gecko rendering engine). Unfortunately I have overwritten the FC5 build, so I
cannot test without the flash plugin to see if that was related to the
occasional lock-ups.

Thought it might be a useful input. Let me know if it is worth while running any
other tests for my FC6 install.
Comment 6 Warren Togami 2006-08-20 11:56:57 EDT
PAY ATTENTION to my above comment.

All existing versions of Flash for Linux are currently broken on FC5+.  You must
disable X composite or use the XLIB_SKIP_ARGB_VISUALS=1 workaround when you
first run firefox.  You must also "ln -s /etc/X11/fs/config
/usr/X11R6/lib/X11/fs/config" in order for it to find fonts.
Comment 7 David Cartwright 2006-09-05 21:08:22 EDT
Thanks Warren,

I hear you :)

I note that a recent FC6T2 update has added the XLIB_SKIP_ARGB_VISUALS statement
by default to the /usr/bin/firefox file.

btw ... for future readers, prior to creating the link for the fonts, the
directory structure has to be created as follows:

mkdir -p /usr/X11R6/lib/X11/fs/
Comment 8 Warren Togami 2007-01-10 15:33:28 EST

*** This bug has been marked as a duplicate of 155582 ***

Note You need to log in before you can comment on or make changes to this bug.