Bug 202342 - Trackpoint does not work on Thinkpad T43p after instalation
Trackpoint does not work on Thinkpad T43p after instalation
Status: CLOSED DUPLICATE of bug 200347
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-13 04:14 EDT by Jiri Cerny
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-14 12:14:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jiri Cerny 2006-08-13 04:14:04 EDT
Description of problem:
After a fresh instalation of FC6T2 on T43p the trackpoint and the corresponding
line of buttons does not work in X. The touchpad and its two buttons are without
problems.  

Version-Release number of selected component (if applicable):
FC5T2 version

  
Actual results:
Trackpoint does not work, touchpad does


Expected results:
both works. I do not care about the trackpoint to much, but I tend to use its
middle button, because touchpad does not have one. See
http://www.thinkwiki.org/wiki/UltraNav for a picture of the device.


Additional info:
I modified /etc/X11/xorg.conf file in the following way and the bug disappears
(I copied it from FC5 system):
into the ServerLayout section add
        InputDevice    "Mouse0" "AlwaysCore"
and add the section
Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option      "Protocol" "IMPS/2"
        Option      "Device" "/dev/input/mice"
        Option      "ZAxisMapping" "4 5"
        Option      "Emulate3Buttons" "yes"
EndSection
Comment 1 Will Woods 2006-08-14 12:14:28 EDT
Another workaround - on my T43, removing all "InputDevice" sections allows xorg
to properly autodetect all pointer devices (trackpoint, touchpad, and USB mice).
Xorg is supposed to be autodetecting the devices, so the InputDevice sections
may not be necessary.


*** This bug has been marked as a duplicate of 200347 ***

Note You need to log in before you can comment on or make changes to this bug.