Bug 202441 - chroot'd named causes df permission denied error
Summary: chroot'd named causes df permission denied error
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: bind   
(Show other bugs)
Version: 4.4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Adam Tkac
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords: Regression
: 358911 (view as bug list)
Depends On:
Blocks: 203075 234251
TreeView+ depends on / blocked
 
Reported: 2006-08-14 14:45 UTC by John Haxby
Modified: 2015-06-17 13:28 UTC (History)
8 users (show)

Fixed In Version: RHBA-2007-0743
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-15 16:03:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to hide /var/named/proc/chroot (417 bytes, patch)
2006-08-14 14:45 UTC, John Haxby
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0743 normal SHIPPED_LIVE bind bug fix and enhancement update 2007-11-14 17:08:35 UTC

Description John Haxby 2006-08-14 14:45:11 UTC
Description of problem:

After starting the choot'd name df reports

   df: `/var/named/chroot/proc': Permission denied


Version-Release number of selected component (if applicable): bind-9.2.4-16.EL4, 
bind-chroot-9.2.4-16.EL4

How reproducible: Always

Steps to Reproduce:
1. Install bind, bind-chroot and caching-nameserver
2. Start bind
3. run df
  
Actual results:

As above.

Expected results:

No complaints.

Additional info:
I notice that FC5 seems to have fixed this in a different way to the proposed
patch (attached): I think it ignores the bind file system type, though I'm not
certain.  This patch works nicely on RHEL4 though and doesn't cause any problems
that I can detect.

Comment 1 John Haxby 2006-08-14 14:45:14 UTC
Created attachment 134141 [details]
Patch to hide /var/named/proc/chroot

Comment 2 Martin Stransky 2006-08-14 14:54:09 UTC
Thanks for your report.

Comment 4 Jay Turner 2006-08-17 03:46:24 UTC
QE ack for 4.5.

Comment 5 RHEL Product and Program Management 2006-08-18 14:42:12 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 23 Adam Tkac 2007-10-31 10:09:01 UTC
*** Bug 358911 has been marked as a duplicate of this bug. ***

Comment 24 errata-xmlrpc 2007-11-15 16:03:20 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0743.html



Note You need to log in before you can comment on or make changes to this bug.