This service will be undergoing non-disruptive maintenance at 07:20 UTC, 2018-12-14. It is expected to last approximately 30 minutes
Bug 358911 - installation of bind-chroot causes problems with df
Summary: installation of bind-chroot causes problems with df
Status: CLOSED DUPLICATE of bug 202441
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: bind (Show other bugs)
(Show other bugs)
Version: 4.4
Hardware: All Linux
low
low
Target Milestone: ---
: ---
Assignee: Adam Tkac
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-10-30 19:13 UTC by Joseph Shraibman
Modified: 2013-04-30 23:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-31 10:09:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Joseph Shraibman 2007-10-30 19:13:05 UTC
Description of problem:
After installing bind-chroot, df prints this whenever it is run a a non-superuser:
df: `/var/named/chroot/proc': Permission denied

Version-Release number of selected component (if applicable):
coreutils-5.2.1-31.6
bind-chroot-9.2.4-27.0.1.el4

How reproducible:
All the time

Steps to Reproduce:
1. install bind-chroot
2. As a user other than root run 'df'
3.
  
Actual results:
df: `/var/named/chroot/proc': Permission denied

Comment 1 Joseph Shraibman 2007-10-30 19:49:03 UTC
Fixing this problem is as simple as doing "chmod a+rx /var/named/
/var/named/chroot".  Of course df should probably be ignoring filesystems
mounted with the 'bind' option anyway.

This does not appear to be an issue with redhat 5 (it appears that df is fixed
there as the directory permissions are the same).

Comment 2 Adam Tkac 2007-10-31 10:09:00 UTC
Part of 4.6 errata

*** This bug has been marked as a duplicate of 202441 ***


Note You need to log in before you can comment on or make changes to this bug.