Bug 202476 - modesetting i810 driver OK on IBM Thinkpad T43
modesetting i810 driver OK on IBM Thinkpad T43
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
:
: 228045 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-14 14:38 EDT by Will Woods
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-10 18:34:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg log (43.70 KB, text/plain)
2006-08-14 14:38 EDT, Will Woods
no flags Details
Lifebook P7010 Xorg.0.log (42.78 KB, text/plain)
2007-02-18 01:02 EST, Ilpo Nyyssonen
no flags Details

  None (edit)
Description Will Woods 2006-08-14 14:38:25 EDT
X works, AIGLX works. Switching to textmode (VT1) does not work - screen becomes
garbled and that's it - but you can switch back without a problem.
Comment 1 Will Woods 2006-08-14 14:38:26 EDT
Created attachment 134157 [details]
Xorg log
Comment 2 Will Woods 2006-08-14 14:40:11 EDT
Forgot to mention - this machine uses the 915GM chipset, and the package version
is xorg-x11-drv-i810-1.6.4-3.fc6
Comment 3 Ilpo Nyyssonen 2007-02-18 01:02:46 EST
Created attachment 148277 [details]
Lifebook P7010 Xorg.0.log

I too have garbled console. I have vga=0x318 in the kernel command line.
Comment 4 Ilpo Nyyssonen 2007-02-18 02:10:14 EST
Is Bug 228045 same thing as this one?

Without the vga=0x318 in kernel command line the console is just flickers a lot,
but is readable. (When switching back from X of course.)
Comment 5 Matěj Cepl 2007-02-27 15:46:10 EST
*** Bug 228045 has been marked as a duplicate of this bug. ***
Comment 6 Matěj Cepl 2007-02-27 15:46:14 EST
*** Bug 228191 has been marked as a duplicate of this bug. ***
Comment 7 Adam Jackson 2007-04-10 18:34:15 EDT
As of xorg-x11-drv-i810-1.6.5-19.fc7, 915GM and all 945 and 965 chips will use
the intel modesetting driver by default.  Please update, and test with that
driver, and reopen if you have further issues.

Note You need to log in before you can comment on or make changes to this bug.