Bug 228045 - Return from VT switch very very bad (modesetting)
Return from VT switch very very bad (modesetting)
Status: CLOSED DUPLICATE of bug 202476
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-09 13:13 EST by Bill Nottingham
Modified: 2014-03-16 23:05 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-27 15:45:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
X log (88.87 KB, text/plain)
2007-02-09 13:15 EST, Bill Nottingham
no flags Details
xorg conf file (567 bytes, text/plain)
2007-02-09 13:16 EST, Bill Nottingham
no flags Details
probably useless video capture (174.64 KB, application/ogg)
2007-02-09 13:56 EST, Bill Nottingham
no flags Details

  None (edit)
Description Bill Nottingham 2007-02-09 13:13:21 EST
Description of problem:

Using i965, intel driver.

When returning from a switch to a VT, X goes nutso.

Will try and dig up a movie, but the thought process is:
"Wow, that's screwy."
"This is probably bad for epileptics."
"It's like it lost vertical/horizontal hold on a old analog TV."
"I didn't know you could *do* that with a LCD."

Version-Release number of selected component (if applicable):

xorg-x11-drv-i810-1.6.5-11.fc7
xorg-x11-server-Xorg-1.2.0-5.fc7

How reproducible:

Every time.

Steps to Reproduce:
1. Start X.
2. Switch to a VC.
3. Switch back.
  
Actual results:

Melty vibrating crazy chaos.
Comment 1 Bill Nottingham 2007-02-09 13:15:21 EST
Created attachment 147789 [details]
X log
Comment 2 Bill Nottingham 2007-02-09 13:16:15 EST
Created attachment 147790 [details]
xorg conf file
Comment 3 Bill Nottingham 2007-02-09 13:56:50 EST
Created attachment 147795 [details]
probably useless video capture

Here's some awful video of it. Yay for crappy cell phones.
Comment 4 Andrew Bartlett 2007-02-09 15:09:49 EST
On my i855GM (on a Dell Latitude X300), I get similar results, but only on the
VT, switching back to X makes things good again.
Comment 6 Matěj Cepl 2007-02-27 15:45:57 EST

*** This bug has been marked as a duplicate of 202476 ***

Note You need to log in before you can comment on or make changes to this bug.