Bug 20250 - RH 7 crashes on install
RH 7 crashes on install
Status: CLOSED DUPLICATE of bug 18031
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-02 15:51 EST by Need Real Name
Modified: 2007-04-18 12:29 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-03 14:52:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-11-02 15:51:13 EST
Hi- upgrading to RH 7.0 crashes with bizarre errors. I dumped the error to
a floppy as instructed. Here it is

My system is 3 disks, with many dos partitions. 4th IDE is a cd-writer.
Otherwise yr basic RH 6.0, with many additions and home-compiled kernel.


Traceback (innermost last):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", line
20, in run
    rc = self.todo.doInstall ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1543, in
doInstall
    self.instCallback, p)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1298, in
instCallback
    self.rpmFD = os.open(fn, os.O_RDONLY)
OSError: [Errno 2] No such file or directory:
'/mnt/source/RedHat/RPMS/setup-2.3.4-1.noarch.rpm'

Local variables in innermost frame:
fn: /mnt/source/RedHat/RPMS/setup-2.3.4-1.noarch.rpm
total: 0
self: <todo.ToDo instance at 84a1580>
h: <header object at 89910e0>
amount: 0
intf: <progress_gui.InstallProgressWindow instance at 85134a8>
what: 2

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'currentDisc'
p6
I1
sS'tree'
p7
S'/mnt/source'
sS'device'
p8
S'hdd'
sS'progressWindow'
p9

<failed>
Comment 1 Michael Fulbright 2000-11-03 14:52:28 EST
It appears your CDROM images are corrupt, or your CDROM drive is having
problems.

If you pruchased the CDs you may want to consider getting them replaced.

*** This bug has been marked as a duplicate of 18031 ***

Note You need to log in before you can comment on or make changes to this bug.