Bug 20255 - kickstart: /dev/mouse is created with 'mouse none'
kickstart: /dev/mouse is created with 'mouse none'
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
6.2
i386 Linux
low Severity low
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-02 16:59 EST by Pekka Savola
Modified: 2005-10-31 17:00 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-15 00:50:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pekka Savola 2000-11-02 16:59:08 EST
If you specify 'mouse none' in ks.cfg, /dev/mouse link is still created, to ttyS0.

I don't think this should be done.

I haven't had a chance to see if this is still an issue in RHL7.
Comment 1 Michael Fulbright 2000-11-03 14:49:40 EST
Passed to QA to reproduce.
Comment 2 Bill Nottingham 2000-11-04 02:02:13 EST
If you happen to have a serial mouse plugged in, it's
probably getting created in post-install by kudzu.
Comment 3 Pekka Savola 2000-11-04 03:07:45 EST
There was no mouse plugged in at all.
Comment 4 Brock Organ 2000-11-06 15:09:19 EST
hmmm ... testing Red Hat Linux 7 here w/joe random machine (with mouse NOT
plugged in) ...

/dev/mouse -> /dev/psaux

is this a problem ...?  what circumstances may occur that would make this
harmful ...?
Comment 5 Pekka Savola 2000-11-06 15:27:41 EST
Well, I'm not sure if there's any harm in that, but ttyS0 was bad because 
we used that for serial console...

What if the system doesn't have psaux port (old AT case) or it's disabled?  
I wonder if the link would be created, and pointing where.
Comment 6 Brock Organ 2000-11-06 17:28:47 EST
I would agree that ttyS0 would be a bad link to make ... :) 

what is your hardware configuration on the machine that made the link to ttyS0
...?
Comment 7 Pekka Savola 2000-11-06 17:38:42 EST
The system was P3 w/ i815-based board in ATX case.
Comment 8 Michael Fulbright 2000-12-27 12:17:38 EST
Assigning to a developer.
Comment 9 Andrew Bartlett 2001-02-14 08:51:57 EST
This could be made to go away (at least partly) if /dev/mouse goes away, see bug
23499 (my patch to exchange /dev/mouse in favor of an entry in the X config and
/etc/sysconfig/mouse).
Comment 10 Brent Fox 2001-03-01 22:05:20 EST
Still present in internal builds.
Comment 11 Brent Fox 2001-03-02 19:40:24 EST
I looked at this for quite some time today and the answer is not clear.  I'm
reluctant to change code at this point, especially for something that is not
critical.  This must be fixed in the future, though.  Deferring to a future release.
Comment 12 Michael Fulbright 2001-09-17 15:01:34 EDT
Brent please verify against roswell.
Comment 13 Brent Fox 2001-09-24 12:10:29 EDT
Problem still present in Roswell.
Comment 14 Jeremy Katz 2002-02-14 16:27:22 EST
Bill, would kudzu potentially detect the mouse when we run it in the postinstall
even if the installer has been set up with no mouse?
Comment 15 Bill Nottingham 2002-02-15 00:50:09 EST
Almost certainly, if there is one there. I think the initial bug report is about
a link for a serial mouse being created when there wasn't one present, which is
a somewhat different problem...
Comment 16 Jeremy Katz 2002-02-15 01:36:37 EST
Yeah, that was the original behavior and the bug has evolved over time... that
at least answers the later bit of /dev/mouse pointing to /dev/psaux and thus
it's fairly safe to say that this is fixed in the current release (at least, it
won't cause conflicts with serial consoles)

Note You need to log in before you can comment on or make changes to this bug.