Bug 23499 - [PATCH] RFE: kill /dev/mouse (making devfs support easier)
[PATCH] RFE: kill /dev/mouse (making devfs support easier)
Status: CLOSED WONTFIX
Product: Red Hat Raw Hide
Classification: Retired
Component: mouseconfig (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
David Lawrence
:
Depends On: 23500
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-06 22:16 EST by Andrew Bartlett
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:47:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch for init.d/gpm to use a DEVICE variable and make it usable on devfs (363 bytes, patch)
2001-01-06 23:59 EST, Andrew Bartlett
no flags Details | Diff
Better version of the init.d/gpm patch (368 bytes, patch)
2001-01-07 03:18 EST, Andrew Bartlett
no flags Details | Diff
A patch to mouseconfig.c to make it read and record the device it uses, instead of using the /dev/mouse symlink (4.20 KB, patch)
2001-01-07 03:20 EST, Andrew Bartlett
no flags Details | Diff

  None (edit)
Description Andrew Bartlett 2001-01-06 22:16:00 EST
Why have a /dev/mouse link at all?

Symbolic links in /dev are a good idea for like devices, so cdroms (all of
which look the same to mount and freinds - just block devices) get links to
/dev/cdrom.  But mice don't look the same, and both X and gpm both need to
be told what the mouse behind /dev/mouse is anyway, why not just modify
they configuration files to tell them where to find it as well.  

Mouseconfig already modifies the X configuration files to set the mouse to
/dev/mouse, why not just specify the exact device and be done with it? 
Similarly gpm does not require /dev/mouse, it can be told with -m
/path/to/mouse.

Fixing this will make devfs support easier (RedHat already ships devfsd and
the line in rc.sysinit so users who want it can use it - at least to the
stage of booting), and won't inconvenience other users.

Other approches to this problem, like kudzu modifying the devfsd.conf file
are silly (bug 22810), and this approch can still use the old device names
- with devfsd managing the compatability links as before.

The work involved is only a few lines in /etc/rc.d/init.d/gpm,
/etc/sysconfig/mouse (add a line for the path to the mouse) and
mouseconfig.c (put the path the the mouse, rather that /dev/mouse when
rewriting the config).
Comment 1 Andrew Bartlett 2001-01-06 23:59:30 EST
Created attachment 7164 [details]
patch for init.d/gpm to use a DEVICE variable and make it usable on devfs
Comment 2 Andrew Bartlett 2001-01-07 03:18:59 EST
Created attachment 7166 [details]
Better version of the init.d/gpm patch
Comment 3 Andrew Bartlett 2001-01-07 03:20:37 EST
Created attachment 7167 [details]
A patch to mouseconfig.c to make it read and record the device it uses, instead of using the /dev/mouse symlink
Comment 4 Andrew Bartlett 2001-01-07 03:32:37 EST
This patch implements (along with the patch to gpm's init.d entry, mirrored in
bug 23500) the storage of the mouse device in /etc/sysconfig/mouse, rather than
in the /dev/mouse symbolic link.  This allows for the use of gpm (and presumably
X) on systems with devfs.  It should have no detremental effect on non-devfs
users, and uses the old standard names.  (devfsd provides these as a
compatibility measure, and RedHat ships with devfsd - presumably for user's own
sanity).

My muck-about machine, on which this was developed however does not have X
installed, but the changes to its configuration file seem correct.  Also note
that I am not yet particularly competent in C, but this patch appears to work
and should at least be a good start on implmenting this feature.  

The use of this patch should allow RedHat machines to boot correctly into
gpm-enabled console and X without issues, even if they want to try devfs.
Comment 5 Matt Wilson 2001-01-08 20:05:19 EST
I will have a look at this over the next few days, thanks for the patches.
Comment 6 Andrew Bartlett 2001-03-01 00:31:58 EST
Is this still being looked at?
Comment 7 Brent Fox 2002-10-10 14:16:36 EDT
I have just completed a text mode interface for redhat-config-mouse, which means
that mouseconfig will be deprecated in the next release of Red Hat Linux.  

Therefore, I will not be putting any development time towards fixing mouseconfig
bugs, so I'm closing this as 'wontfix'.
Comment 8 Andrew Bartlett 2002-10-10 18:24:06 EDT
That's fine, but does the new redhat-config-mouse still rely on /dev/mouse?

If so, can this bug be re-assigned to the new program?  If not, then thankyou!

Andrew Bartlett
Comment 9 Red Hat Bugzilla 2006-02-21 13:47:52 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.