Bug 2026209 - Updation of task is getting failed (tekton hub integration)
Summary: Updation of task is getting failed (tekton hub integration)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.9
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.10.0
Assignee: Karthik Jeeyar
QA Contact: spathak@redhat.com
URL:
Whiteboard:
Depends On:
Blocks: 2033274
TreeView+ depends on / blocked
 
Reported: 2021-11-24 05:30 UTC by Veeresh Aradhya
Modified: 2022-03-12 04:39 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-03-12 04:39:01 UTC
Target Upstream Version:
Embargoed:


Attachments (Terms of Use)
Steps to reproduce the issue (1.15 MB, video/webm)
2021-11-24 05:30 UTC, Veeresh Aradhya
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 10653 0 None open Bug 2026209: Fix tektonhub task upgrading issue 2021-12-13 11:24:25 UTC
Red Hat Product Errata RHSA-2022:0056 0 None None None 2022-03-12 04:39:16 UTC

Description Veeresh Aradhya 2021-11-24 05:30:01 UTC
Created attachment 1843306 [details]
Steps to reproduce the issue

Description of problem:
Updation of task is getting failed

Version-Release number of selected component (if applicable):

How reproducible:
All the time

Steps to Reproduce:
1. Install Openshift Pipelines 1.6 on OCP 4.6
2. Navigate pipelines tab and click on Create Pipeline button
3. Click on Add Task button
4. Search for the task "openshift-client" and select the community version of the task
5. Select the older version (0.1) of the task and click on "Install and Add"
6. Click on the Create button
7. Again navigate to pipelines tab and click on Create Pipeline button
8. Search for the task "openshift-client" and select the community version of task
9. Select the newer version (0.2) of the taks and click on "Update and add" button


Actual results:
The latest version of the task is not getting installed


Expected results:
The latest version of the task should get installed and all the pipeline which was using older version of task should use the latest version of the task

Additional info:

Comment 2 Mohammed Saud 2021-12-17 11:37:28 UTC
Verified on:
Build:   4.10.0-0.ci-2021-12-16-184808
Browser: Firefox 95

Comment 6 errata-xmlrpc 2022-03-12 04:39:01 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (Moderate: OpenShift Container Platform 4.10.3 security update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHSA-2022:0056


Note You need to log in before you can comment on or make changes to this bug.