Bug 20276 - Installer fails on Sony Vaio PCG-N505SN
Installer fails on Sony Vaio PCG-N505SN
Status: CLOSED DUPLICATE of bug 18019
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.0
i686 Linux
high Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-03 06:18 EST by Need Real Name
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-03 14:47:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-11-03 06:18:14 EST
When installing RH7 using the boot.img disk and the files on a the local
hard disk, the installation fails during/after the checking packacges stage
with;

Traceback (innermost last:)
File "/usr/bin/anaconda.real", line 438, in ?
  intf.run( todo, test=test)
File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, in run
File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/textw/packages_text.py",
line 33 in __call__
File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/harddrive.py", line 43, in
readComps
File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 459 in
__init__
File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 428, in
readCompsFile
File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 101, in
__getitem__
KeyError: file


Please not this Vaio does not have an internal CDROM or Floppy, both are
attached via a USB port when needed. I am booting successfuly from the
Floppy, and installing from the hard drive as I am aware that RH7 does not
support reading or writing from storage devices via USB.

I am willing to test any fix you may have.
Comment 1 Michael Fulbright 2000-11-03 14:47:19 EST
Please make sure you downloaded all the files for the install with the binary
ftp option.

There is something corrupt about the hard drive install image you are installing
from.

*** This bug has been marked as a duplicate of 18019 ***
Comment 2 Need Real Name 2000-11-04 05:21:00 EST
The image was copied from a CD. The CD has been used to install three other 
machines without issue.

I am unable to use the anacoda unpdate disk as is relies on reading from the 
floppy drive during the install, and as the installer can't read from USB 
storage devices the update disk can't be read.

Please reopen this as a bug as your suggestion using a binary transfer under 
FTP is not applicable.


Note You need to log in before you can comment on or make changes to this bug.