Bug 20294 - LILO option lba32 sometimes needed
Summary: LILO option lba32 sometimes needed
Status: CLOSED DUPLICATE of bug 14351
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer   
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
high
high
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-11-03 19:20 UTC by D. Hugh Redelmeier
Modified: 2005-10-31 22:00 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-03 19:41:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description D. Hugh Redelmeier 2000-11-03 19:20:37 UTC
I installed RHL7.0 via NFS on a recent PC with a large disk.  I placed the
LINUX / partition above 8.5G (above cyl 1024).  The installation appeared
to be done properly.  When the installer invited me to hit return to
reboot, the X screen disappeared to briefly reveal a scary error message on
the text console.  The message was quickly cleared by the rebooting
process.

The reboot failed.  To cut a long story short, the flashed messages were
from LILO, saying:
  Warning: device 0x0307 exceeds 1024 cylinder limit
  Fatal: sector 26948994 too large for linear mode (try 'lba32' instead)
LILO had therefore not installed a boot sector.
The installer should definitely have reported this problem to me.  It
should have provision to rectify it.  It is lucky that I created a boot
floppy.
The man pages for lilo and lilo.conf make no mention of lba32.  I found
that replacing "linear" with "lba32" in /etc/lilo.con fixed the problem.

Comment 1 Michael Fulbright 2000-11-03 19:41:47 UTC

*** This bug has been marked as a duplicate of 14351 ***

Comment 2 Matt Wilson 2000-11-03 22:09:45 UTC
Boot the installer with "linux lba32" per the note in RELEASE-NOTES on the CD.




Note You need to log in before you can comment on or make changes to this bug.