Bug 14351 - RFE:lba32 support should be added as an option on lilo configuratio
RFE:lba32 support should be added as an option on lilo configuratio
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Jeremy Katz
: FutureFeature
: 16639 16982 18044 18974 20294 20984 31494 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-07-20 20:43 EDT by Arenas Belon, Carlo Marcelo
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-11 18:46:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Arenas Belon, Carlo Marcelo 2000-07-20 20:43:49 EDT
just as linear is shown as "recomended" option on LILO configuration, lba32
should be allowed too.

lba32 (a nifty new feature of lilo) would allow a user (usually on dual
boot systems) to boot linux if the kernel is below the 1024 cilinder.

as linear (better on SCSI) and lba32 (better on IDE) are mutually
exclusive, it should be added as a new mutually exclusive selection.

it would allow "Joe Costumer" to dual boot easyly and try linux, without
fear of ending with a "L" or "LI" message on boot.
Comment 1 Milan Kerslager 2000-07-25 16:41:59 EDT
There is still no button for LBA32 in Beta4. Will be wery bad if there will not
exist this button for 7.0. LILO is ready so... please...
Comment 2 Milan Kerslager 2000-07-27 11:33:42 EDT
There is still no lba32... :-(
Comment 3 Erik Troan 2000-08-04 11:18:59 EDT
This was brought up too late for us to change installs screens to do docs
freeze.
Comment 4 Michael Fulbright 2000-09-26 16:56:33 EDT
Related to bug 16639.
Comment 5 Michael Fulbright 2000-10-02 18:12:10 EDT
*** Bug 18044 has been marked as a duplicate of this bug. ***
Comment 6 Michael Fulbright 2000-10-09 15:40:50 EDT
*** Bug 16982 has been marked as a duplicate of this bug. ***
Comment 7 Michael Fulbright 2000-10-09 15:42:11 EDT
*** Bug 16639 has been marked as a duplicate of this bug. ***
Comment 8 Michael Fulbright 2000-10-18 18:03:04 EDT
*** Bug 18974 has been marked as a duplicate of this bug. ***
Comment 9 Michael Fulbright 2000-11-03 14:41:44 EST
*** Bug 20294 has been marked as a duplicate of this bug. ***
Comment 10 Michael Fulbright 2000-11-17 15:26:02 EST
*** Bug 20984 has been marked as a duplicate of this bug. ***
Comment 11 Michael Fulbright 2000-11-20 15:18:33 EST
Added support to libfdisk, required testing.
Comment 12 Brock Organ 2000-12-08 11:54:33 EST
Using internal tree (qa1206.0 w/updates disk), the lba32 option is present in
the lilo.conf file genereated by the install, but is still not an option present
in the GUI interface ...
Comment 13 Brock Organ 2001-01-09 10:53:05 EST
the lba support has been added to the back end (ie lba should be used in
lilo.conf when /boot is above 1024 cyl and the drive bios supports it), but
there may not be any user interface control for this feature added for this
release ...
Comment 14 Michael Fulbright 2001-04-11 16:16:03 EDT
*** Bug 31494 has been marked as a duplicate of this bug. ***
Comment 15 Jeremy Katz 2001-07-16 15:45:32 EDT
New button added for lba32 support in internal trees.

Note You need to log in before you can comment on or make changes to this bug.