Bug 2029571 - Azure Stack Hub: CSI Driver does not use user-ca-bundle
Summary: Azure Stack Hub: CSI Driver does not use user-ca-bundle
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Storage
Version: 4.9
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.9.z
Assignee: Fabio Bertinatto
QA Contact: Wei Duan
URL:
Whiteboard:
Depends On: 2029570
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-12-06 19:31 UTC by Patrick Dillon
Modified: 2022-01-24 16:50 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 2029570
Environment:
Last Closed: 2022-01-24 16:50:19 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift azure-disk-csi-driver-operator pull 39 0 None open [release-4.9] Bug 2029571: Add custom CA bundle support 2022-01-13 16:20:58 UTC
Github openshift library-go pull 1279 0 None Merged [release-4.9] Bug 2029571: csi: add hook to inject custom CA bundle 2022-01-13 16:20:58 UTC
Red Hat Product Errata RHBA-2022:0195 0 None None None 2022-01-24 16:50:30 UTC

Comment 4 Mike Gahagan 2022-01-18 22:59:22 UTC
Confirmed CSI driver is working correct on Azure Stack Hub with the user supplied ca bundle using 4.9.0-0.nightly-2022-01-17-145110

Comment 8 errata-xmlrpc 2022-01-24 16:50:19 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.9.17 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2022:0195


Note You need to log in before you can comment on or make changes to this bug.