Bug 20323 - "Error mounting hdb1: Invalid argument"
"Error mounting hdb1: Invalid argument"
Status: CLOSED DUPLICATE of bug 16686
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-03 19:13 EST by Adam
Modified: 2007-04-18 12:29 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-07 10:18:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
"Error mounting hdb1: Invalid argument". Attached to bug 20323 (898 bytes, text/plain)
2000-11-03 19:17 EST, Adam
no flags Details

  None (edit)
Description Adam 2000-11-03 19:13:39 EST
Formating the file system (for a workstation install) goes OK until it 
finishes the /var partition on the slave IDE hard disk.  I then receive 
the following error meesage... 

"Error mounting hdb1: Invalid argument.  An internal error occurred in the
installation process".  

A week before, I successfully installed the Red Hat server on the slave 
drive which was the primary drive at the time. 

Could the Master Boot Record on the current slave be a problem?  Could it 
have LILO still installed in the MBR from my original installation?  I 
used a Win 98 startup disk and then did a <fdisk /mbr> at the A:\ prompt, 
in an attempt to restore the MBR.
From Win98 fdisk it says it has an Active non-dos partition, so how can I
blow this away and leave it totally clean for linux hdb.   Windows fdisk
will not let me delete this 'unknown' partition.

Here is the code that I saved:

Traceback (innermost last):
  File "/usr/bin/anaconda", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, in 
run
    rc = apply (step[1](), step[2])
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 507, in 
__call__
    if todo.doInstall ():
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1472, in 
doInstall
    self.fstab.mountFilesystems (self.instPath)
  File "fstab.py", line 715, in mountFilesystems
    raise SystemError, (errno, msg)
SystemError: (22, 'Invalid argument')

Local variables in innermost frame:
size: 945976
fsystem: ext2
self: <fstab.NewtFstab instance at 8244e38>
msg: Invalid argument
doFormat: 1
errno: 22
device: hdb1
instPath: /mnt/sysimage
mntpoint: /home

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>
Comment 1 Adam 2000-11-03 19:17:03 EST
Created attachment 5035 [details]
"Error mounting hdb1: Invalid argument".  Attached to bug 20323
Comment 2 Michael Fulbright 2000-11-07 10:18:25 EST

*** This bug has been marked as a duplicate of 16686 ***

Note You need to log in before you can comment on or make changes to this bug.