Bug 20332 - up2date dies on download errors
Summary: up2date dies on download errors
Status: CLOSED DUPLICATE of bug 18994
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: up2date   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Preston Brown
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-11-04 14:06 UTC by David Woodhouse
Modified: 2007-04-18 16:29 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-04 14:06:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description David Woodhouse 2000-11-04 14:06:37 UTC
This failure mode appears to have been triggered by a failure to download
the complete file for a glibc update. Bringing up a window to complain
about it would be preferable.

Actually, I didn't notice this in the terminal from which up2date was
started for some time - because I've got used to the fact that it just sits
there and fails to even redraw its windows while it's doing something else.
That is also a severe defect in its functionality, IMO.

imladris /home/dwmw2 # up2date
Traceback (innermost last):
  File "/usr/share/rhn/up2date/gui.py", line 356, in doRetrieval
    res = up2date.hasBadSignature(self.selectedPkgList[index])
  File "/usr/share/rhn/up2date/up2date.py", line 806, in hasBadSignature
    hdr = rpm.headerFromPackage(fd)[0]
rpm.error: error reading package

Comment 1 Preston Brown 2000-11-28 20:08:19 UTC

*** This bug has been marked as a duplicate of 18994 ***

Comment 2 David Woodhouse 2000-11-28 22:33:07 UTC
This doesn't look like a duplicate of 18994. This appears to be caused by an
aborted download of the package and a subsequent failure to read the RPM headers
of the new package, rather than a failure to grok the system's RPM database.

The other part: "just dies horribly without bringing up a dialog box to complain
and you don't notice for hours because you've come to _expect_ it not to redraw
itself for ages anyway" is the same though.


Note You need to log in before you can comment on or make changes to this bug.