Bug 18994 - up2date hangs durring 'Removing packages ...'
up2date hangs durring 'Removing packages ...'
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
Aaron Brown
:
: 20332 20392 21071 22781 22974 23118 23129 23691 24323 33768 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-12 16:22 EDT by Morgan Deegan
Modified: 2007-04-18 12:29 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-09 03:04:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Morgan Deegan 2000-10-12 16:22:13 EDT
After repeatedly running Update Agent from the gui, I started it from a
term Session and when it reached the point of the hang, the following text
was outputed. The GUI Screen stays 'Removing packages with files marked to
skip from list' at 2%

[root@samson /]# up2date
Traceback (innermost last):
  File "/usr/lib/python1.5/site-packages/libglade.py", line 28, in __call__
    ret = apply(self.func, a)
  File "/usr/share/rhn/up2date/gui.py", line 164, in onStartPageNext
    (self.pkgList, self.skipPkgList) =
up2date.getUpdatedPackageList(pwin.setLabel, pwin.setProgress)
  File "/usr/share/rhn/up2date/up2date.py", line 894, in
getUpdatedPackageList
    progressCallback)
  File "/usr/share/rhn/up2date/up2date.py", line 851, in
removeSkipFilesPackagesFromList
    if checkModified(h, f_i):
  File "/usr/share/rhn/up2date/up2date.py", line 770, in checkModified
    installedHdr = installedHeader(hdr['name'])
  File "/usr/share/rhn/up2date/up2date.py", line 162, in installedHeader
    for index in db.findbyname(pkgName):
rpm.error: error reading from database
Comment 1 bjarke 2000-10-14 12:44:05 EDT
Hi

I have precisely the same problem. Except it only shows 1% instead of 2%. The
line numbers are not equal (different versions?):

[me@mypc bin]$ up2date
Traceback (innermost last):
  File "/usr/lib/python1.5/site-packages/libglade.py", line 28, in __call__
    ret = apply(self.func, a)
  File "/usr/share/rhn/up2date/gui.py", line 164, in onStartPageNext
    (self.pkgList, self.skipPkgList) =
up2date.getUpdatedPackageList(pwin.setLabel, pwin.setProgress)
  File "/usr/share/rhn/up2date/up2date.py", line 897, in getUpdatedPackageList
    progressCallback)
  File "/usr/share/rhn/up2date/up2date.py", line 854, in
removeSkipFilesPackagesFromList
    if checkModified(h, f_i):
  File "/usr/share/rhn/up2date/up2date.py", line 773, in checkModified
    installedHdr = installedHeader(hdr['name'])
  File "/usr/share/rhn/up2date/up2date.py", line 162, in installedHeader
    for index in db.findbyname(pkgName):
rpm.error: error reading from database

I have RH 7.0 and all updates. (so up2date is 2.0.6-1).

/Bjarke
Comment 2 Scott Thomson 2000-10-18 07:38:41 EDT
I have exactly the same problem with the same error messages.

However I only get the error when the: "Display all packages available, not only
those installed on the system" is checked in my Red Hat Network configuration.

When I try with any other configuration it (seems to) work fine. Returning the
"your system is fully updated" message.
Comment 3 Need Real Name 2000-10-19 22:35:24 EDT
I get something similar after running the GUI version it just sits there stuck
at 3% removing packages.  I then ran it via the command line and got the
following just doing an "up2date --list"  I even upgraded the version of
uptodate that I have to the very latest but its still not working...

Retrieving list of all available packages...

Removing installed packages from list of updates...
100.0%
Removing packages marked to skip from list...
100.0%
Getting headers for available packages...
100.0%
Removing packages with files marked to skip from list...
Traceback (innermost last):
  File "/usr/sbin/up2date", line 382, in ?
    main()
  File "/usr/sbin/up2date", line 366, in main
    sys.exit(batchRun(onlyList, pkgNames))
  File "/usr/sbin/up2date", line 138, in batchRun
    updated, skipped = up2date.getUpdatedPackageList(printit, percent)
  File "/usr/share/rhn/up2date/up2date.py", line 894, in getUpdatedPackageList
    progressCallback)
  File "/usr/share/rhn/up2date/up2date.py", line 851, in
removeSkipFilesPackagesFromList
    if checkModified(h, f_i):
  File "/usr/share/rhn/up2date/up2date.py", line 770, in checkModified
    installedHdr = installedHeader(hdr['name'])
  File "/usr/share/rhn/up2date/up2date.py", line 162, in installedHeader
    for index in db.findbyname(pkgName):
rpm.error: error reading from database
Comment 4 bjarke 2000-10-20 12:05:21 EDT
I tried to follow Scoots advice (unchecking "Display all packages available, not
only                those installed on the system") and it worked for me too...

/Bjarke
Comment 5 Morgan Deegan 2000-10-20 16:45:29 EDT
I also tried unchecking the Display All Packages option. It sort of worked for 
me. It woul get past where it was hanging before and I would be able to select 
the packages. It would download ONE package and then hang with an error message 
stating Invalid Architecture OS type. If I then canceled out and reran up2date, 
it would go past the down load of the last package and verify with the MD5 
thing and download the next package repeating the error. I repeated the 
sequence untill all selected packages were downloaded and it then proceded to 
install them.
Comment 6 Preston Brown 2000-11-28 11:08:42 EST
Jeff:

Looking at this bug, would you assume these people have corrupted RPM databases?
Comment 7 Preston Brown 2000-11-28 11:29:08 EST
*** Bug 20392 has been marked as a duplicate of this bug. ***
Comment 8 Preston Brown 2000-11-28 11:53:48 EST
*** Bug 21071 has been marked as a duplicate of this bug. ***
Comment 9 Preston Brown 2000-11-28 15:01:11 EST
*** Bug 21071 has been marked as a duplicate of this bug. ***
Comment 10 Preston Brown 2000-11-28 15:08:13 EST
*** Bug 20332 has been marked as a duplicate of this bug. ***
Comment 11 Preston Brown 2000-11-28 15:10:42 EST
*** Bug 21071 has been marked as a duplicate of this bug. ***
Comment 12 Preston Brown 2000-12-21 14:35:16 EST
These users have corrupted RPM databases.  There is no way to fix this
currently.
Comment 13 Jeff Johnson 2000-12-21 14:43:51 EST
Actually, it's hard to tell what's up. Could you try doing (db_dump is in the
db3-utils package)

	cd /var/lib/rpm
	db_dump Packages > /dev/null

and report if you see a Berkeley db assertion failed message? Thanks.
Comment 14 Preston Brown 2000-12-27 16:55:33 EST
*** Bug 22781 has been marked as a duplicate of this bug. ***
Comment 15 Bjarke Skjernaa 2000-12-28 05:26:07 EST
I tried to do

[a@b rpm]$ pwd
/var/lib/rpm
[a@b rpm]$ db_dump Packages > /dev/null
[a@b rpm]$

so no errors. After I have updated to the new version of up2date
(up2date-2.1.7-1) the problem resist but has changed. I no more get any error
messages. It goes into some kind of infinite loop (it uses more and more memory
(17 MB after 2 minutes of CPU-time)): 

PID USER     PRI  NI  SIZE  RSS SHARE STAT %CPU %MEM   TIME COMMAND
1207 root      12   0 18768  18M  5320 S    81,0 29,8   2:16 up2date

The window "Update Agent Progress" gets to "Getting headers for available
packages" (progress bar says 100 % - but I think that is a left-over from
"Removing installed packages from list of updates"). Neither the main window nor
the progress window updates (stays gray when something has been in front of
them). When the mouse is over the progress window the cursor is a watch
(indicating that it is working).

It still only a problem if "Display all packages available, not only those
installed on the system" is checked.
Comment 16 Preston Brown 2001-02-08 22:45:43 EST
*** Bug 24323 has been marked as a duplicate of this bug. ***
Comment 17 Preston Brown 2001-02-08 22:47:50 EST
*** Bug 22974 has been marked as a duplicate of this bug. ***
Comment 18 Preston Brown 2001-02-08 22:48:46 EST
*** Bug 23118 has been marked as a duplicate of this bug. ***
Comment 19 Preston Brown 2001-02-08 22:49:21 EST
*** Bug 23129 has been marked as a duplicate of this bug. ***
Comment 20 Preston Brown 2001-02-09 00:29:03 EST
*** Bug 23691 has been marked as a duplicate of this bug. ***
Comment 21 imorgan 2001-02-09 03:04:05 EST
Ran db3_dump Packages >/dev/null and got no errors at all. Even if the databases
were corrupted, I would expect rpm --rebuilddb to fix things, but up2date still
fails after doing that.
Comment 22 Preston Brown 2001-02-14 21:36:48 EST
fixed in rawhide version 2.5 and later.  An errata will be forthcoming at some
point in the future. For now, don't use up2date's "-a" option, and/or turn off
"Retrieve all packages."
Comment 23 Preston Brown 2001-03-30 22:13:29 EST
*** Bug 33768 has been marked as a duplicate of this bug. ***
Comment 24 Stephane Marchand 2002-04-25 11:21:58 EDT
My problem looks like this but :
hanging at 100%, in the GUI, after
finishing installation of all packages(400mb)

It actually downloaded and installed everything
but I cannot get back the focus on the OK button.
grayed out, not available :(

Note You need to log in before you can comment on or make changes to this bug.