Bug 203322 - Mouse pointer
Mouse pointer
Status: CLOSED DUPLICATE of bug 182517
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nv (Show other bugs)
5
x86_64 Linux
medium Severity urgent
: ---
: ---
Assigned To: Ray Strode [halfline]
Mike McLean
http://fedora.redhat.com/Download/
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-21 00:31 EDT by Satish
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-29 10:12:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Satish 2006-08-21 00:31:48 EDT
Description of problem:
After complete installation of Fedora Core 5 on AMD Athlon 64 machine, mouse
pointer disappears after login screen appears. However full functionalites of
mouse can be used. The problem is visiblity after login screen appearance.

Version-Release number of selected component (if applicable):
Fedore Core 5 (Latest)

How reproducible:
Can install on AMD Athon 64 machine, using x86_64 iso files that are available
on any mirror sites on http://fedora.redhat.com/Download/ site

Steps to Reproduce:
1.Install on AMD Athlon 64 machine
2.After installation wait for login screen
3.When login screen appears problem can be visible.
  
Actual results:
Mouse pointer not visible after loging in.

Expected results:
Mouse pointer should appear

Additional info:
When SUSE 10.0 was used this problem didnot occur, however SUSE was for 32 bit
processor.
Comment 1 Karel Zak 2006-08-21 09:25:33 EDT
Do you really mean login on text console?
Comment 2 Satish 2006-08-21 23:44:50 EDT
Dear Karel,
I would split the process of loading Fedora on system in 2 parts
1. Booting process where all drivers and other software are getting loaded

2. After booting is completed, an user login screen appears, where the user 
has to text type his userid and further password, enabling user to start using 
Fedora.

Well the problem starts from part 2, i.e. after entire booting is over (i 
guess).
Comment 3 Darlene J. Ford 2006-08-27 22:38:14 EDT
I have the same problem after installing FC6 on an AMD Athlon machine.  
Additional notes:

-The mouse cursor is visible while Fedora 6 is booting, and disappears when 
the pretty Fedora graphic with the login screen appears.
-The mouse behaves correctly except that the cursor is invisible.  
-Changing the mouse cursor has no effect.
-The "Highlight mouse on Ctrl" feature works correctly, so you can kind of 
sort of find the mouse while you're trying to fix this.  (Look under the 
system mouse menu.)
-I am using a Logitech USB mouse that works just fine on another computer, 
specifically, an x86 box running FC3.
-My AMD Athlon based PC is a dual boot system, and the mouse that isn't 
working with Fedora 6 works just fine under Windows NT.
Comment 4 Darlene J. Ford 2006-08-27 22:40:25 EDT
Okay, I'm an idiot.  I meant FC5.
Comment 5 Darlene J. Ford 2006-08-27 23:55:15 EDT
This may be related to bug 193520, 185268, 185820, and 185217.  I also have an 
nvidia graphics card similar to the one mentioned there, specifically the 
GeForce 6150LE.

Satish-

Which graphics card do you have?  BTW, if you happen to have bought the same 
Compaq sale model I did, I'd love to compare notes with you. Drop me an e-mail 
if you're so inclined.

Please let us know if you try any of the work arounds listed. It may be a 
couple of days before I get back to this myself.

Some workarounds are mentioned at 
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=185820
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=193520

Comment 6 Satish 2006-08-28 09:45:11 EDT
Hi Karel,
I was playing around the FC5 and could find something that might be 
interesting for de-bugging.

1. For Windows and FC5 system after GRUB2 is being loaded, i hit the ENTER key 
to enter into options for OS menu. (I mean list of OS present on the system.

2. After this i press 'a' for Fedora Core 5, as mentioned below (This changes 
the kernal arguments ?, Options present are e, a and c for command prompt)

3. After the bash prompt appears, with backspace i just delete that appears on 
the prompt( if i remember it is something like ro = \Fedora....(many 
characters.. rhgb quiet IF I'M, NOT WRONG). 
   Then press ENTER key to go ahead with booting of FC5. (Interestingly this 
time systems booting in a different way, i guess)

4. And Voila !!! we have mouse pointer that is visible, with its full 
functionalities through out the session.

I have not yet explored the impact of this procedure, but atleast i get to 
work around in a peaceful way.

Hope this helps to understand the problem in a different way.
Comment 7 Ray Strode [halfline] 2006-08-28 09:54:59 EDT
Satish,

if you just delete the "rhgb" part, does that workaround your problem? (instead
of the whole line)
Comment 8 Satish 2006-08-28 10:04:27 EDT
Hi Ray,
       I have not explored this aspect i shall do that and come back to you. 
By the way what does it mean/signify.

Satish
Comment 9 Ray Strode [halfline] 2006-08-28 10:47:35 EDT
If "rhgb" is on the kernel command line then it will launch a graphical program
during the boot process to show status instead of just booting on the text console.
Comment 10 Darlene J. Ford 2006-08-28 22:57:28 EDT
Satish dropped me a note to say ....

> Well i have an AMD Athlon 64 with nVidia Graphics card
> with GeForce 6100 on  Gigabyte motherboard...  I'm sorry to disappoint you,
>since my computer is an assembled and not branded. Secondly i'm from INDIA, so
> i guess hardware at your place (if i'm not wrong,
> USA), is faster and cheaper than in here,

Actually, it sounds a lot like my long-shelf-life sale PC from Staples and a lot
like a duplicate of bug 185217.  Did I understand correctly that they had
several workarounds, but were waiting on nVidia for a permanent fix?
Comment 11 Darlene J. Ford 2006-08-28 23:05:44 EDT
Satish dropped me a note to say ....

> Well i have an AMD Athlon 64 with nVidia Graphics card
> with GeForce 6100 on  Gigabyte motherboard...  I'm sorry to disappoint you,
>since my computer is an assembled and not branded. Secondly i'm from INDIA, so
> i guess hardware at your place (if i'm not wrong,
> USA), is faster and cheaper than in here,

Actually, it sounds a lot like my long-shelf-life sale PC from Staples and a lot
like a duplicate of bug 182517.  Did I understand correctly that they had
several workarounds, but were waiting on nVidia for a permanent fix?
Comment 12 Satish 2006-08-28 23:57:42 EDT
Hi Ray,
       As mentioned i tried removing 'rhgb quiet' from the prompt and allow 
the machine to boot with other command arguments. And yes it is affirmative 
that mouse pointer is visible on the screen.

So i guess we can pinpoint that, grahic based booting has missed something 
that has not during booting on text console. Can we take a hint from this ?

However after i complete working with FC5 and logout to return to the user 
login screen, the mouse pointer is again invisible. So i have to reboot and 
follow the painful proces, till FC5 team finds an solution to this teething 
problem.

Also i have recently read BUG 193520 as referred by Darlene Ford, and the 
explanation from Mike Harris. It seems that we with this problem since before. 
So i would say sorry for the trouble, since it being already handled by .....

Hi Darlene,
Yes i think you have done a lot of BUG STUDY. The problems are definately long 
pending ones, especially for nVidia Chipset. Also the video problems are 
indeed present as they are mentioned. (The same videos run good in P4 machines 
with FC5)

Also Mike Harris mentions that we may have to wait for FC 6 for this issue to 
be resolved. How long for FC 6 ?
Comment 14 Darlene J. Ford 2006-08-29 23:29:07 EDT
If I edit the string "rhgb" out of /etc/grub.conf my PC also boots up with a 
working mouse.  I didn't try logging out and back in again yet.  Satish, do 
you get any improvment in your results if you edit the grub.conf file and 
reboot?

[Cursing the young whippersnapper who decided not to include emacs in the 
default install.  Kids these days...]

[The original nv-mouse discussion is rather technical.  Willing to post a 
summary for the casual user if anyone expresses an interest.]
Comment 15 Darlene J. Ford 2006-08-30 21:14:53 EDT
Nope.  Still loses mouse when I log out, even with the grub.conf edit.  

Note You need to log in before you can comment on or make changes to this bug.