Bug 203350 - ia64 build fails due to typo in mk-images.ia64
ia64 build fails due to typo in mk-images.ia64
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
ia64 Linux
urgent Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
: 203028 (view as bug list)
Depends On:
Blocks: fedora-ia64
  Show dependency treegraph
 
Reported: 2006-08-21 09:28 EDT by Prarit Bhargava
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-22 11:24:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Fix typo in mk-images.ia64 (471 bytes, patch)
2006-08-21 09:28 EDT, Prarit Bhargava
no flags Details | Diff

  None (edit)
Description Prarit Bhargava 2006-08-21 09:28:47 EDT
Description of problem:

The nightly ia64 build is failing due to a typo in mk-images.ia64

Version-Release number of selected component (if applicable):
anaconda-11.1.0.83-1


How reproducible: 100%


Steps to Reproduce:
1. Attempt to build a distro with anaconda

  
Actual results:

Build fails with 

el-2.6.17-1.2571.fc6.ia64.rpm.ia64
/mnt/redhat/nightly/rawhide-20060817/work/ia64-global/buildinstall.tree.11363/mk-images.ia64:
line 110: [: !: binary operator expected
Building ia64 guest initrd.img
Wrote /tmp/makebootdisk.initrdimage.22598 (9372k compressed)
cp: cannot stat
`/tmp/updboot.kernel.22598/ia64/boot/efi/EFI/redhat/vmlinuz-*xen*': No such file
or directory
unpacking
/mnt/redhat/nightly/rawhide-20060817/work/ia64-global/Fedora/RPMS/kernel-xen-2.6.17-1.2571.fc6.ia64.rpm.ia64
/mnt/redhat/nightly/rawhide-20060817/work/ia64-global/buildinstall.tree.11363/mk-images.ia64:
line 110: [: !: binary operator expected

Expected results:

Build should succeed.

Additional info:  Jeremy, this is critical for ia64.  Patch attached.
Comment 1 Prarit Bhargava 2006-08-21 09:28:56 EDT
Created attachment 134559 [details]
Fix typo in mk-images.ia64
Comment 2 Prarit Bhargava 2006-08-21 10:37:02 EDT
*** Bug 203028 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.