Bug 2034640 - cant delete VM with un-owned pvc attached
Summary: cant delete VM with un-owned pvc attached
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Kubevirt Plugin
Version: 4.8
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.8.z
Assignee: Aviv Turgeman
QA Contact: Guohua Ouyang
URL:
Whiteboard:
Depends On: 2034829
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-12-21 15:19 UTC by Igor Braginsky
Modified: 2022-01-11 22:31 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-01-11 22:31:17 UTC
Target Upstream Version:
Embargoed:
aturgema: needinfo-


Attachments (Terms of Use)
VM can't be removed (66.40 KB, image/png)
2021-12-21 15:19 UTC, Igor Braginsky
no flags Details
disk_delete_video (1.35 MB, application/octet-stream)
2022-01-04 02:19 UTC, Guohua Ouyang
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 10718 0 None Merged Bug 2034640: cant delete VM with un-owned pvc attached 2022-02-03 12:07:45 UTC
Red Hat Product Errata RHBA-2022:0021 0 None None None 2022-01-11 22:31:21 UTC

Description Igor Braginsky 2021-12-21 15:19:27 UTC
Created attachment 1847195 [details]
VM can't be removed

Created attachment 1847195 [details]
VM can't be removed

Description of problem: Can't remove VM migrated from VMWare in UI, delete button never becomes active


Version-Release number of selected component (if applicable):


How reproducible: 100%


Steps to Reproduce:
1. Migrate VM from VMWare
2. Wait until migration will end successfully
3. Try to delete that VM


Actual results:
Confirmation pop-up opens, but delete button never becomes active. See the screenshot for details

Expected results:


Additional info:
Reproduced both for CEPH and NFS storage types
Didn't reproduce for VMs migrated from RHV

Comment 1 Igor Braginsky 2021-12-21 15:21:46 UTC
Forgot to mention, that from CLI vm was removed with no problems, so that is just UI issue

Comment 2 Guohua Ouyang 2021-12-22 01:22:51 UTC
The bug is very similar with https://bugzilla.redhat.com/show_bug.cgi?id=2019717.

Aviv, could you take a look at this issue?

Comment 3 Guohua Ouyang 2021-12-22 01:25:33 UTC
https://bugzilla.redhat.com/show_bug.cgi?id=2019717 the issue also existed on 4.8.z as it's not backported to 4.8.z.

Comment 4 Guohua Ouyang 2021-12-22 01:49:24 UTC
It seems the problem caused by it's using PVC instead of data volume while migrating VM from VMware.

Comment 5 Igor Braginsky 2021-12-22 05:42:40 UTC
Doublechecked, that VM migrated from RHV can be removed as usual, so problem is relevant for VMWare only

Comment 7 Guohua Ouyang 2022-01-04 02:19:45 UTC
Created attachment 1848765 [details]
disk_delete_video

verified on openshift/console release-4.8

Comment 12 errata-xmlrpc 2022-01-11 22:31:17 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.8.26 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2022:0021


Note You need to log in before you can comment on or make changes to this bug.