Bug 2034829 - cant delete VM with un-owned pvc attached
Summary: cant delete VM with un-owned pvc attached
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Kubevirt Plugin
Version: 4.9
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.9.z
Assignee: Yaacov Zamir
QA Contact: Guohua Ouyang
URL:
Whiteboard:
Depends On: 2019717
Blocks: 2034640
TreeView+ depends on / blocked
 
Reported: 2021-12-22 09:44 UTC by Guohua Ouyang
Modified: 2022-01-10 08:51 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 2019717
Environment:
Last Closed: 2022-01-10 08:50:46 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 10719 0 None open Bug 2034829: cant delete VM with un-owned pvc attached 2021-12-26 15:30:50 UTC
Red Hat Product Errata RHBA-2022:0029 0 None None None 2022-01-10 08:51:15 UTC

Description Guohua Ouyang 2021-12-22 09:44:42 UTC
+++ This bug was initially created as a clone of Bug #2019717 +++

Description of problem:
initially introduced in https://bugzilla.redhat.com/show_bug.cgi?id=2018428#c22
When trying to delete a VM with a disk (PVC) attached which is not owned by the VM, 'Delete Virtual Machine' modal is stuck on loading


Version-Release number of selected component (if applicable):
master

How reproducible:
100%

Steps to Reproduce:
1. attach a disk to a VM an existing pvc (VM status should be off/stopped) 
2. delete VM after disk attach
3.

Actual results:
Modal is stuck with spinner (looks like it's stuck on loading)

Expected results:
Modal opens and finishes loading, and the Delete button is enabled to delete.

Additional info:

--- Additional comment from OpenShift Automated Release Tooling on 2021-11-03 20:26:34 CST ---

Elliott changed bug status from MODIFIED to ON_QA.
This bug is expected to ship in the next 4.10 release created.

--- Additional comment from Guohua Ouyang on 2021-11-03 21:06:40 CST ---

Test on master, now the delete modal load normally and vm got deleted.

https://bugzilla.redhat.com/show_bug.cgi?id=2018428#c28, it mentioned "Provide an optional check box for each unowned disk so that it can also be deleted", but there is no such checkbox for unowned disk to be deleted, is it been discussed?

--- Additional comment from Yaacov Zamir on 2021-11-03 21:26:24 CST ---

> https://bugzilla.redhat.com/show_bug.cgi?id=2018428#c28, it mentioned "Provide an optional check box for each unowned disk so that it can also be deleted", but there is no such checkbox for unowned disk to be deleted, is it been discussed?

For this bug fix, please ignore the RFEs we discussed in: https://bugzilla.redhat.com/show_bug.cgi?id=2018428#c16 and https://bugzilla.redhat.com/show_bug.cgi?id=2018428#c20
As a bug fix we only fixed the none working checkbox.

--- Additional comment from OpenShift BugZilla Robot on 2021-11-04 05:48:25 CST ---

Bug will not be automatically moved to VERIFIED for the following reasons:
- PR openshift/console#10390 not appoved by QA contact
- PR openshift/console#10390 does not have the qe-approved label
- `Verified` field of this bug is not set to `Tested`

--- Additional comment from Guohua Ouyang on 2021-11-04 07:52:48 CST ---

Move the bug to verified, the delete modal load normally and unowned disk is not deleted.

Comment 2 Guohua Ouyang 2022-01-04 01:36:48 UTC
verified on openshift/console release-4.9

Comment 6 errata-xmlrpc 2022-01-10 08:50:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.9.13 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2022:0029


Note You need to log in before you can comment on or make changes to this bug.