Bug 20350 - RedHat Linux 7 Hard Drive Installation Failure
Summary: RedHat Linux 7 Hard Drive Installation Failure
Status: CLOSED DUPLICATE of bug 18019
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda
Version: 7.0
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-11-05 02:34 UTC by Need Real Name
Modified: 2005-10-31 22:00 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2000-11-07 17:22:04 UTC


Attachments (Terms of Use)
RedHat Linux 7 Hard Drive Installation Failure Error Message (984 bytes, text/plain)
2000-11-05 02:37 UTC, Need Real Name
no flags Details

Description Need Real Name 2000-11-05 02:34:44 UTC
I was trying to install RedHat Linux 7 from my hard drive. After I 
finished a series of installation options, the installer started to look 
for packages to install. Then, it stopped and the following error message 
appeared.


Traceback (innermost last):
  File "/usr/bin/anaconda.real", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, in 
run
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/textw/packages_text.py", 
line 33, in __call__
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 539, in 
getCompsList
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/harddrive.py", line 43, 
in readComps
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 459, in 
__init__
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 428, in 
readCompsFile
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 101, in 
__getitem__
KeyError: pwdb

Local variables in innermost frame:
self: <comps.HeaderList instance at 82d3240>
item: pwdb

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iharddrive
HardDriveInstallMethod
p4
(dp5
S'fstype'
p6
S'vfat'
p7
sS'isMounted'
p8
I1
sS'fnames'
p9
(dp10

<failed>

Comment 1 Need Real Name 2000-11-05 02:37:15 UTC
Created attachment 5038 [details]
RedHat Linux 7 Hard Drive Installation Failure Error Message

Comment 2 Michael Fulbright 2000-11-07 17:22:01 UTC
This occurs when the hard drive install image is corrupted. Please make sure you
have properly set it up.

*** This bug has been marked as a duplicate of 18019 ***


Note You need to log in before you can comment on or make changes to this bug.