Bug 203507 - error when using "Add/Remove Software"
error when using "Add/Remove Software"
Status: CLOSED DUPLICATE of bug 186545
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-22 02:07 EDT by npmak
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-22 17:26:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
error message (877 bytes, text/plain)
2006-08-22 02:07 EDT, npmak
no flags Details

  None (edit)
Description npmak 2006-08-22 02:07:10 EDT
Description of problem:

At first, an error message "cannot retrieve software information" popped up 
after clicking "Add/Remove Software" under "Applications" menu. My computer 
was not connected to internet. Then, I followed the steps below which claimed 
to solve this issue.

==========================================================================
Create a directory for your repository and mount the DVD ISO there: 
# mkdir -p /path/to/your/repo 
# mount -r -o loop /path/to/FC-5-i386-DVD.iso /path/to/your/repo
Ensure that the DVD ISO image is mounted at every reboot 
edit /etc/fstab and add new line: 

/path/to/FC-5-i386-DVD.iso /path/to/your/repo iso9660 ro,loop 0 0 
Configure yum to use your new repository 

edit /etc/yum.repos.d/fedora-core.repo 

comment out any line starting with baseurl or mirrorlist in the [core] 
repository section at the top 

add a new line: baseurl=file:///path/to/your/repo

If you want to use the Add/Remove Software application (pirut) with no network 
connection, you'll need to disable all of the yum repositories apart from your 
local one. By default, the only enabled repositories are core (which is now 
served by your local repository), updates, and extras. You can disable these 
repositories by changing the line enabled=1 to enabled=0 
in /etc/yum.repos.d/fedora-updates.repo and /etc/yum.repos.d/fedora-
extras.repo respectively.

=============================================================================

After performing the above steps, another error popped up. And it suggested me 
to save the error message and report this error. The error message is attached.

Version-Release number of selected component (if applicable):
FC5

How reproducible:
everytime

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 npmak 2006-08-22 02:07:10 EDT
Created attachment 134614 [details]
error message
Comment 2 Jeremy Katz 2006-08-22 17:26:41 EDT

*** This bug has been marked as a duplicate of 186545 ***

Note You need to log in before you can comment on or make changes to this bug.