Bug 203514 - Bugzilla marks "bug + newline + number" as a link to a bug
Bugzilla marks "bug + newline + number" as a link to a bug
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
2.8
All All
low Severity low (vote)
: ---
: ---
Assigned To: Bernd Groh
David Lawrence
https://bugzilla.redhat.com/bugzilla/...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-22 04:23 EDT by Jan Pazdziora
Modified: 2014-06-18 04:21 EDT (History)
1 user (show)

See Also:
Fixed In Version: 2.18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-22 15:30:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Pazdziora 2006-08-22 04:23:54 EDT
Description of problem:

The bugzilla seems to mark "bug\s+\d+" as a link to bug within bugzilla. This
should probably be changed to something like "bug +\d+", to prevent the link
from appearing when there is a newline, which seems to denote that the word bug
is not related to the number following on the next line.

Version-Release number of selected component (if applicable):

Current (2.18)

How reproducible:

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=202653

Steps to Reproduce:
1. https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=202653
2. observe the "Steps to Reproduce"
  
Actual results:

The word "bug" and the number "2" are a link to
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=2, because of the following
HTML code:

this <span class="bz_closed"><a href="show_bug.cgi?id=2" title="CLOSED FIXED -
broken links of default index.html">bug
2</a></span>. run

Expected results:

There should be not link there.
Comment 1 Jan Pazdziora 2006-08-22 04:24:45 EDT
Hmmm. It did it again in my report. ;-)
Comment 2 David Lawrence 2006-08-22 15:30:46 EDT
Should be fixed now. Thanks for the report.

Note You need to log in before you can comment on or make changes to this bug.