Bug 203542 - a -devel package should be split of ppp
Summary: a -devel package should be split of ppp
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: ppp
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Martin Nagy
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 226313
TreeView+ depends on / blocked
 
Reported: 2006-08-22 12:56 UTC by Patrice Dumas
Modified: 2016-07-26 23:46 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-03-12 09:31:12 UTC
Type: ---


Attachments (Terms of Use)
Patch to move all header files to ppp-devel package (949 bytes, patch)
2008-03-06 23:17 UTC, Martin Nagy
no flags Details | Diff

Description Patrice Dumas 2006-08-22 12:56:48 UTC
Description of problem:

I guess the include files are only used to develop plugins, so 
it would make sense to split them out of ppp, in a ppp-devel
package which should also contain the PLUGINS file in %doc.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Patrice Dumas 2006-11-17 15:55:11 UTC
Maybe it is the right time to make that change
such that it leaves time to workaround things that break?


Comment 2 Martin Nagy 2008-03-06 23:17:50 UTC
Created attachment 297123 [details]
Patch to move all header files to ppp-devel package

Comment 3 Martin Nagy 2008-03-06 23:18:39 UTC
Could I have your thoughts on this Patrice?

Comment 4 Patrice Dumas 2008-03-07 08:38:54 UTC
There is a 
%defattr(-,root,root,-)
missing for the -devel package.

I also think that this subpackage should have
%doc PLUGINS
(and PLUGINS be removed from main package %doc)


Comment 5 Martin Nagy 2008-03-07 09:31:23 UTC
About the PLUGINS, I was considering to move it, but then it seemed to me a bit
waste to have just this one file in a special directory. Also I think that there
are few bits of information useful even for a non-developer.

Comment 6 Martin Nagy 2008-03-12 09:31:12 UTC
ok, I included the PLUGINS in the -devel package after all.
Fixed with ppp-2.4.4-6.fc9

Comment 7 Martin Nagy 2008-03-12 09:45:56 UTC
Changing component back to ppp, I have no idea how the heck did it change to
"4suite"


Note You need to log in before you can comment on or make changes to this bug.