Bug 226313 - Merge Review: ppp
Merge Review: ppp
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jiri Popelka
Fedora Package Reviews List
:
Depends On: 203542
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-31 15:42 EST by Nobody's working on this, feel free to take it
Modified: 2010-01-22 10:27 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-22 10:27:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
jpopelka: fedora‑review+


Attachments (Terms of Use)

  None (edit)
Description Nobody's working on this, feel free to take it 2007-01-31 15:42:45 EST
Fedora Merge Review: ppp

http://cvs.fedora.redhat.com/viewcvs/devel/ppp/
Initial Owner: twoerner@redhat.com
Comment 1 Jiri Popelka 2009-11-25 11:23:05 EST
formal review is here, see the notes below:

YES source files match upstream:
  183800762e266132218b204dfb428d29  ppp-2.4.4.tar.gz
YES package meets naming and versioning guidelines.
YES specfile is properly named, is cleanly written and uses macros consistently.
YES dist tag is present.

YES build root is correct.
 BuildRoot in spec file has value: %{_tmppath}/%{name}-root
According to https://fedoraproject.org/wiki/Packaging:Guidelines#BuildRoot_tag
the BuildRoot value MUST contain at least %{name}, %{version} and %{release}.
I'm giving YES because the RPM in Fedora 10 and above defines a default buildroot
so in Fedora 10 and above it is no longer necessary to define a buildroot tag. 

YES license field matches the actual license.
YES license is open source-compatible.

NO License text included in package.
 I didn't find license text

NO latest version is being packaged.
 ppp-2.4.5.tar.gz has been released 11/17/2009

NO BuildRequires are proper.
 Build requirements are proper but they are defined in BuildPrereq (should be BuildRequires)

YES compiler flags are appropriate.
YES %clean is present.
YES package builds in mock (Rawhide/x86_64).
YES debuginfo package looks complete.

NO rpmlint is silent.
ppp.src: W: summary-ended-with-dot The PPP (Point-to-Point Protocol) daemon.
ppp.src: W: name-repeated-in-summary PPP
ppp.src: W: no-url-tag
ppp.src:33: E: buildprereq-use pam-devel, libpcap-devel
ppp.src:84: W: configure-without-libdir-spec
ppp.src:337: W: macro-in-%changelog %{_mandir}
ppp.src: W: mixed-use-of-spaces-and-tabs (spaces: line 51, tab: line 303)
ppp.x86_64: W: summary-ended-with-dot The PPP (Point-to-Point Protocol) daemon.
ppp.x86_64: W: name-repeated-in-summary PPP
ppp.x86_64: W: no-url-tag
ppp.x86_64: E: non-standard-dir-perm /var/log/ppp 0700
ppp.x86_64: E: non-standard-executable-perm /usr/sbin/pppoe-discovery 0555
ppp.x86_64: E: non-readable /etc/ppp/chap-secrets 0600
ppp.x86_64: E: non-readable /etc/ppp/pap-secrets 0600
ppp.x86_64: E: non-standard-executable-perm /usr/sbin/pppd 0555
ppp-debuginfo.x86_64: W: no-url-tag
ppp-devel.x86_64: W: no-url-tag
4 packages and 0 specfiles checked; 6 errors, 11 warnings.

YES final provides and requires look sane.
N/A %check is present and all tests pass.
YES no shared libraries are added to the regular linker search paths.
YES owns the directories it creates.
YES doesn't own any directories it shouldn't.
YES no duplicates in %files.

NO file permissions are appropriate.
 see rpmlint errors

YES no scriptlets present.
YES code, not content.
YES documentation is small, so no -docs subpackage is necessary.
YES %docs are not necessary for the proper functioning of the package.
YES no headers.
YES no pkgconfig files.
YES no libtool .la droppings.
YES not a GUI app.
Comment 2 Jiri Popelka 2009-11-26 01:38:47 EST
Sorry for the false positive about latest version not being packaged. There's ppp-2.4.5.tar.gz in devel branch and matches upstream.
Comment 3 Jiri Skala 2010-01-22 10:11:38 EST
- license texts are in sourcese. no copying 
- some rpmlint complains fixed
- permissions restricted due to security
- latest version updated
Comment 4 Jiri Popelka 2010-01-22 10:27:26 EST
Approved

Note You need to log in before you can comment on or make changes to this bug.