Bug 2035520 (ChromiumEPEL9) - Please branch and build chromium for EPEL 9
Summary: Please branch and build chromium for EPEL 9
Keywords:
Status: CLOSED ERRATA
Alias: ChromiumEPEL9
Product: Fedora EPEL
Classification: Fedora
Component: chromium
Version: epel9
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tom "spot" Callaway
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 2082737 2082739 (view as bug list)
Depends On: 2082681 2048608 2082674 2082684
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-12-24 12:16 UTC by Neal Gompa
Modified: 2022-07-01 01:37 UTC (History)
7 users (show)

Fixed In Version: chromium-102.0.5005.115-1.el8 chromium-102.0.5005.115-2.el9 chromium-102.0.5005.115-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-07-01 00:44:50 UTC
Type: Task


Attachments (Terms of Use)

Description Neal Gompa 2021-12-24 12:16:27 UTC
Please consider branching and building chromium for EPEL 9 so users on EL9 systems can use Chromium just as users on EL8 systems can.

Comment 1 Michel Alexandre Salim 2022-04-27 23:47:47 UTC
Looks like spot branched and built this but it failed:

https://koji.fedoraproject.org/koji/taskinfo?taskID=84838300

I did some dependency analysis and it doesn't look too bad, 7 dependencies missing. Some of them are super weird though - libgnome-keyring is not present ?!

{
  "chromium": {
    "build": {
      "google-croscore-fonts": [
        "google-croscore-arimo-fonts",
        "google-croscore-cousine-fonts",
        "google-croscore-tinos-fonts"
      ],
      "google-noto-fonts": [
        "google-noto-sans-symbols2-fonts"
      ],
      "libusb-compat-0.1": [
        "libusb-compat-0.1-devel"
      ],
      "libgnome-keyring": [
        "pkgconfig(gnome-keyring-1)"
      ],
      "python-html5lib": [
        "python3-html5lib"
      ]
    }
  },
  "google-croscore-fonts": {
    "build": {}
  },
  "google-noto-fonts": {
    "build": {}
  },
  "libusb-compat-0.1": {
    "build": {}
  },
  "libgnome-keyring": {
    "build": {}
  },
  "python-html5lib": {
    "build": {
      "python-genshi": [
        "python3dist(genshi)"
      ],
      "python-webencodings": [
        "python3dist(webencodings)"
      ]
    }
  },
  "python-genshi": {
    "build": {}
  },
  "python-webencodings": {
    "build": {}
  }

Comment 2 Neal Gompa 2022-04-27 23:57:20 UTC
libgnome-keyring was replaced with libsecret, that's why.

Comment 3 Tomas Popela 2022-05-09 06:42:41 UTC
*** Bug 2082737 has been marked as a duplicate of this bug. ***

Comment 4 Tomas Popela 2022-05-09 06:42:45 UTC
*** Bug 2082739 has been marked as a duplicate of this bug. ***

Comment 5 Fedora Update System 2022-06-22 14:58:33 UTC
FEDORA-EPEL-2022-0dde709329 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2022-0dde709329

Comment 6 Fedora Update System 2022-06-22 14:58:36 UTC
FEDORA-EPEL-2022-002f30f00a has been submitted as an update to Fedora EPEL 9. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2022-002f30f00a

Comment 7 Fedora Update System 2022-06-22 14:58:37 UTC
FEDORA-EPEL-2022-3a6675bd1a has been submitted as an update to Fedora EPEL 8. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2022-3a6675bd1a

Comment 8 Fedora Update System 2022-06-23 01:30:40 UTC
FEDORA-EPEL-2022-3a6675bd1a has been pushed to the Fedora EPEL 8 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2022-3a6675bd1a

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 9 Fedora Update System 2022-06-23 01:41:11 UTC
FEDORA-EPEL-2022-002f30f00a has been pushed to the Fedora EPEL 9 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2022-002f30f00a

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 10 Fedora Update System 2022-06-23 01:47:54 UTC
FEDORA-EPEL-2022-0dde709329 has been pushed to the Fedora EPEL 7 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2022-0dde709329

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 11 Fedora Update System 2022-07-01 00:44:50 UTC
FEDORA-EPEL-2022-3a6675bd1a has been pushed to the Fedora EPEL 8 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 12 Fedora Update System 2022-07-01 01:07:03 UTC
FEDORA-EPEL-2022-002f30f00a has been pushed to the Fedora EPEL 9 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 13 Fedora Update System 2022-07-01 01:37:08 UTC
FEDORA-EPEL-2022-0dde709329 has been pushed to the Fedora EPEL 7 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.