Bug 2036747 - Please branch and build python-responses in epel9
Summary: Please branch and build python-responses in epel9
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: python-responses
Version: epel9
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Felix Schwarz
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 2045987 (view as bug list)
Depends On:
Blocks: 2035376 2045985
TreeView+ depends on / blocked
 
Reported: 2022-01-03 19:53 UTC by Alessio
Modified: 2022-02-11 00:26 UTC (History)
5 users (show)

Fixed In Version: python-responses-0.18.0-1.el9
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-02-11 00:26:04 UTC
Type: Bug


Attachments (Terms of Use)

Description Alessio 2022-01-03 19:53:14 UTC
Please branch and build python-responses in epel9.

If you do not wish to maintain python-responses in epel9,
or do not think you will be able to do this in a timely manner,
I would be happy to be a co-maintainer of the package.

Comment 1 Orion Poplawski 2022-01-15 04:01:46 UTC
Let's see if we can get RedHat to ship it - see bug #2040998

Comment 2 Michel Alexandre Salim 2022-01-20 22:10:00 UTC
(In reply to Orion Poplawski from comment #1)
> Let's see if we can get RedHat to ship it - see bug #2040998

per Miro, it's actually retired. It bit me a few times already, the package is in gitlab but once you browse, there's a dead.package.

Athos or @

Comment 3 Michel Alexandre Salim 2022-01-20 22:11:52 UTC
Athos or @fschwarz - could you help branch and build this? (accidentally submitted before finishing my comment, sorry)

The EPEL Packaging SIG would be happy to be a co-maintainer if you do not wish to build it on epel9 (please add the epel-packagers-sig group as collaborator on epel* branches)

Additionally, I would be happy to be a co-maintainer if you do not wish to build it for epel9 (FAS salimma).

Comment 4 Pavel Raiskup 2022-01-26 07:48:24 UTC
*** Bug 2045987 has been marked as a duplicate of this bug. ***

Comment 5 Felix Schwarz 2022-01-26 07:54:48 UTC
Michel: sorry, did not see your comment earlier and I did not realize I became an admin some time ago so I thought this was just part of the python-sig stack. I'll go through the issues this evening and get everything updated/branched.

However I always like additional co-maintainers. EPEL sig+salimma FTW. What is the EPEL sig user name to use in pagure?

Comment 6 Felix Schwarz 2022-01-26 10:37:25 UTC
quick question: How can I run a mockbuild for EPEL 9 manually? 

$ mock --rebuild -r /etc/mock/epel-next-9-x86_64.cfg python-responses-0.17.0-1.fc36.src.rpm
...
No match for argument: fedpkg-minimal
Error: Unable to find a match: fedpkg-minimal

Any way to trigger a local build?

Comment 7 Pavel Raiskup 2022-01-26 14:01:16 UTC
By `mock -r centos-stream+epel-9-x86_64 ...`.

Comment 8 Felix Schwarz 2022-01-26 14:55:38 UTC
@Pavel: Thanks, that worked for me (after installing the mock packages from updates-testing)

epel9 branch requested: https://pagure.io/releng/fedora-scm-requests/issue/41352

@Michel: I made you a co-admin for python-responses. I can do the initial EPEL 9 build but I'm absolutely happy if someone else also has an eye on python-responses. Feel free to add also the EPEL-sig.

Comment 9 Fedora Update System 2022-01-26 16:23:24 UTC
FEDORA-EPEL-2022-051178a1ea has been submitted as an update to Fedora EPEL 9. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2022-051178a1ea

Comment 10 Fedora Update System 2022-01-27 19:12:12 UTC
FEDORA-EPEL-2022-051178a1ea has been pushed to the Fedora EPEL 9 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2022-051178a1ea

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 11 Fedora Update System 2022-02-03 01:27:44 UTC
FEDORA-EPEL-2022-051178a1ea has been pushed to the Fedora EPEL 9 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2022-051178a1ea

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 12 Fedora Update System 2022-02-11 00:26:04 UTC
FEDORA-EPEL-2022-051178a1ea has been pushed to the Fedora EPEL 9 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.