Bug 2037500 - CNO: verify job is broken since yaml-patch has disappeared
Summary: CNO: verify job is broken since yaml-patch has disappeared
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 4.9
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.8.z
Assignee: Maysa Macedo
QA Contact: zhaozhanqi
URL:
Whiteboard:
Depends On: 2037499
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-01-05 18:25 UTC by Maysa Macedo
Modified: 2022-01-25 12:13 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 2037499
Environment:
Last Closed: 2022-01-25 12:13:09 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-network-operator pull 1271 0 None open Bug 2037500: Bump openshift/build-machinery-go 2022-01-14 12:01:52 UTC
Red Hat Product Errata RHBA-2022:0172 0 None None None 2022-01-25 12:13:25 UTC

Description Maysa Macedo 2022-01-05 18:25:25 UTC
+++ This bug was initially created as a clone of Bug #2037499 +++

+++ This bug was initially created as a clone of Bug #2037496 +++

Description of problem:

The verify job has been failing reporting the following message:
 mkdir -p '_output/tools/bin/'
curl -s -f -L https://github.com/krishicks/yaml-patch/releases/download/v0.0.10/yaml_patch_linux -o '_output/tools/bin/yaml-patch'
make: *** [ensure-yaml-patch] Error 22 

This is happening because yaml-patch no long exists. To fix it the build-machinery-go dependency needs to be bumped since it already fixed[1] the issue.

[1] https://github.com/openshift/build-machinery-go/pull/58

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 zhaozhanqi 2022-01-17 09:07:57 UTC
Verify this bug

Comment 6 errata-xmlrpc 2022-01-25 12:13:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.8.28 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2022:0172


Note You need to log in before you can comment on or make changes to this bug.